Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дан массив из N элементов. определить количество элементов, кратных 3, но не кратных 5

5-9 класс

Ilyak03 28 янв. 2017 г., 3:39:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cepgey
28 янв. 2017 г., 4:39:22 (7 лет назад)

var
    a: array[1..100] of integer;
    k, i, n: integer;

begin
    read(n);
    for i := 1 to N do
    begin
        A[i] := random(40) - 20;
       
        if (a[i] mod 3 = 0) and (a[i] mod 5 > 0) then
            k := k + 1;
        Write(a[i], ' ');
    end;
    WriteLn();
    WriteLn(k);
end.

+ 0 -
кломтик
28 янв. 2017 г., 6:43:21 (7 лет назад)

Комментарий удален

+ 0 -
Vitopahom
28 янв. 2017 г., 7:15:46 (7 лет назад)

ABC

+ 0 -
Svekuramshina
28 янв. 2017 г., 9:35:16 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

помогите!!!!! Завтра ЗАЧЕТ!!!

Даны действительные числа x, y. Если x иДаны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

графический редактор это - ...

Читайте также

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале -20 до 15 2)Требуется

подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8

3)Дан одномерный числовой массив,изменить знак элементов массива К[1;12] на противоположный



Вы находитесь на странице вопроса "дан массив из N элементов. определить количество элементов, кратных 3, но не кратных 5", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.