Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

мне нужно написать программу калькулятор с функцией нахождения факториала числа

5-9 класс

Potemkina190420 20 авг. 2013 г., 6:21:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kikley
20 авг. 2013 г., 8:55:21 (10 лет назад)

Program fact;
uses crt;
var n,i,s:integer;
beginS:=1;
write('Введите число - ');
readln(n);
If n<=0 then
write('Ваше число либо отрицательное, либо равно нулю. Факториал 0!=1')
else begin
for i:=1 to n do
S:=s*i;
write('Факториал Вашего числа равен - ',s);
end;
end.

+ 0 -
19Иришка19
20 авг. 2013 г., 11:21:33 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Постройте модель следующего процесса, соблюдая основные этапы моделирования:

Гражданин Петров взял в долг у своего приятеля Сидорова 9800р., выдав последнему вексель, по которому обязался выплатить 10000р. через 3 месяца. Под какой долговой процент выдан вексель?

для передачи по каналу связи сообщения состоящего только из символов а б в и г используется посимвольное кодирование а-0 б-1 в-10 г-11 через канал связи

передаётся сообщение гаваб можно ли при таком кодировании однозначно расшифровать полученное сообщение

Читайте также

нужно написать программу (packal abc). программа такая: введи три числа (неизвесно какие 3 числа (целые или вещественные) так что 6 чисел ну типа

такого: var a,b,c:(integer)-целые; l,k,n:(real)-вещественные), найти сумму первых двух чисел, частное второго и третьего числа и утроить сумму трёх чисел. мне нужно составить программу дальше я знаю только начало: program ur1; var a,b,c:integer; l,k,n:real; begin и всё я дальше не могу сделать, помогите полажуйста чем можете!

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Здравствуйте, мне нужна помощь с программой Excel.

Есть программа, которая преобразует слово из трех букв в число в 32-ичной сс(русс. алф).
После этого, переводит число в 10-ую сс.
Максимум может получиться 6 цифр, минимум 3.
Мне
нужно как-то сделать так, чтобы если у меня три цифры, то добавлялось
спереди три нуля, четыре цифры-добавлялось два нуля, пять
цифр-добавлялся один ноль, шесть-не добавлялось ни одного нуля.

Оооочень нужна помощь, помогите с информатикой, плиз

1.Вводится действительное число x. Вычислить значение функции x^3+(2√(x-2))/(3+x^2 )
Нужно написать программу в Pascal.
2.Написать программу для задачи: вводится двухзначное число, выяснить из одинаковых цифр оно состоит или нет.



Вы находитесь на странице вопроса "мне нужно написать программу калькулятор с функцией нахождения факториала числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.