Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать

10-11 класс

программу pascal, которая упорядочивает заданную последо­вательность по убыванию с
помощью сортировки обменами. Сортировка обменами заключается в следующем:
просматривается массив с начала и до конца, и каждый раз сравниваются два
соседних элемента A(i), и A(i+1), если A(i)<A(i+1), то они меняются местами. Просмотр массива с начала и до
конца происходит до тех пор, пока все элементы не упорядочатся.

Kapaap 06 сент. 2013 г., 15:27:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Seruy2212
06 сент. 2013 г., 16:27:37 (10 лет назад)

const n=20;
var a:array [1..n] of integer;
i,j,k:integer;
begin
for i:=1 to n do begin
a[i]:=random(21)-10;
write (a[i]:4);
end;
writeln;
for j:=1 to n do 
for i:=1 to n-1 do
if a[i]<a[i+1] then begin
k:=a[i];
a[i]:=a[i+1];
a[i+1]:=k;
end;
for i:=1 to n do 
write (a[i]:4);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста создать сайт!!

<HTML><HEAD><META http-equiv="Content-Type"content="text/html; charset=windows-1251"><TITLE>Выравнивание и абзацы</TITLE></HEAD><BODY >
</BODY></HTML>
Уточнение<B> </B> Полужирный шрифт<I> </I> Курсив<S> </S> Зачеркнутый текст<U> </U> Подчеркивание
нужно сделать как на фото показано.

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

Одномерные массивы. 3 задачки))

1) Из элементов данного массива W[1..20] создать 2 новых массива, первый из которых содержит только положительные элементы, а второй только отрицательные.

2) Заполнить СЛУЧАЙНЫМИ числами в диапазоне от 1 до 10 два массива A[20] и B[20]. Найти и вывести на экран только те элементы этих массивов и их номера, значения которых попарно совпадают.
Например, если A[2]=B[2]=4, то на экран надо вывести: Номер-2, значение-4.
3) Заменить найденный минимальный элемент числом 100 и показать на экране массив с этой заменой.

Читайте также

Написать подпрограмму, вычисляющую натуральную степень

числа. паскаль
написать программу на компьютере и проверить правильность
работы Вашей процедуры/функции, в этом случае в основной программе
должны быть реализованы ввод исходных данных и вызов
процедуры/функции.

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Написать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.