Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

составить алгоритм вычисления расстояния между 2 точками задаными на плоскости их координатами

5-9 класс

Doroshka13 10 нояб. 2015 г., 7:13:53 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polino4ka98
10 нояб. 2015 г., 8:56:26 (8 лет назад)

program xxx;

    var d, x1, x2, y1,y2 : real;

begin

  write('введите координаты 1 точки:');

  readln(x1, y1);

  write('введите координаты 2 точки:');

  readln(x2, y2);

  d:=sqrt(sqr(x2-x1)+sqr(y2-y1));

  write('растояние между точками =', d);

  readln

end.

Ответить

Другие вопросы из категории

Pascal

известна масса каждого из 12 предметов, определить массу самого тяжелого

Пожалуйста сделайте # 2
1) В некоторой стране автомобильный номер длиной 7 символов составляется из заглавных букв (всего используется 18 букв) и десятичных цифр в любом порядке.

Каждый символ кодируется одинаковым и минимально возможным количеством бит, а каждый номер – одинаковым и минимально возможным целым количеством байт. Определите объем памяти, необходимый для хранения 60 автомобильных номеров.
1) 240 байт 2) 300 байт 3) 360 байт 4) 420 байт

Помогите решить задание по информатике!!

Читайте также

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),



Вы находитесь на странице вопроса "составить алгоритм вычисления расстояния между 2 точками задаными на плоскости их координатами", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.