Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

10-11 класс

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

шрек1 25 окт. 2013 г., 16:05:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kateaster1
25 окт. 2013 г., 16:46:48 (10 лет назад)

1.program z;
var a:array [1..10] of integer; i,t:integer; s:real;
begin
for i:=1 to 10 do
begin
a[i]:=random(1,100);
write(a[i]:4);
if (odd(i)) and (odd(a[i])) then
begin
s:=s+a[i];
t:=t+1;
end;
end;
writeln;
write('Cреднее арифметическое = ',s/t);
end.
2.program z;
var a:array[1..10] of integer; max,i:integer;
begin
writeln('Исходный массив');
for i:=1 to 10 do
begin
a[i]:=random(1,100);
write(a[i]:4);
if a[i]>max then max:=a[i];
end;
writeln;
writeln('Измененный массив');
for i:=1 to 10 do
begin
if not(odd(a[i])) then a[i]:=max;
write(a[i]:4);
end;
end.

Ответить

Другие вопросы из категории

помогите решить задачку пожалуйста: Для хранения в растровом графическом файле изображения размером 640×1504 пикселей отвели 705 Кбайт памяти(без учёта

размера заголовка).Каково максимально возможное число цветов в палитре изображения?

Program_v1;

var A: array [1..20] of integer;

i,s:integer;

begin

randomize;

s:=0;

for i:=1 to 20 do

begin

A[i]:=random(100);

write (' ',A[i] ');

end;

for i:=1 to 20 do

if imod2>0 then

s: = a[i]*a[i];

writeln;

writeln('s=',s);

readln;

end.
генератором случайных чисел (от 0 до 100) задан массив из 20 целых
чисел.составьте программу, с помощью которой напечатайте на одной
строчке исходный массив, а на следующей строке - сумму квадратов
элементов с начетными индексами

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14

Помогите с тестом по информатике

Читайте также

Помогите, пожалуйста. Паскаль ABC. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите произведение элементов, имеющих

нечетные индексы. Выведите на экран исходный массив и полученное произведение.

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

на минимальный. Выведите на экран исходный и полученный массивы.

Помогите, пожалуйста. Паскаль ABC

Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите разность наибольшего и наименьшего элементов. Выведите на экран полученный массив и полученную разность.



Вы находитесь на странице вопроса "1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.