Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решение по С++

1-4 класс

Вы моделируете работу бортового компьютера пассажирского авиалайнера.
Известно оставшееся расстояние до пункта назначения (в км), текущее время (в Ч М
С) и заданное время прибытия (в Ч М С). Чтобы прибыть в пункт назначения
вовремя, выдайте пилоту рекомендуемую скорость полета (в км/ч).

AnnyaT 30 апр. 2015 г., 10:49:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Snezhana2904200
30 апр. 2015 г., 12:37:14 (9 лет назад)

#include "stdafx.h"
#include <iostream>
#include <ctime>

using namespace std;

int _tmain(int argc, _TCHAR* argv[])
{
  int h, m, s, km;
  cin >> h;
  cin >> m;
  cin >> s;
  cin >> km;
  if (km == 0) return 1; //Мы же не хотим, чтобы самолёт ушёл "в исключение"?
  struct tm seconds;
  __time64_t long_time;
  _time64( &long_time ); 
  _localtime64_s(&seconds, &long_time);
  cout << "Recommended speed: " << km / ((h + m / 60 + s / 3600) - (seconds.tm_hour + seconds.tm_min / 60 + seconds.tm_sec / 3600)) << " km/h" << endl;
  char c;
  cin >> c;
  return 0;
}

Ответить

Читайте также

CОС НАРОД ПОМОЩЬ МНЕ ПО ИКТ !!!!!!!!!!!!!!!!!!!!!!!

пожаааа
По вертикали 1: Испонитель команд в программе ПервоЛого.
По горизонтали 2: Свойство алгоритма, означающее, что исполнение последовательность команд приводит к ожидаемому результату
По вертикали 3: Свойство алгоритма, означающее, что каждая команда имеет только одно значение.
По горизонтали 4: Объект, который может точно выполнить команды.
По горизонтали 5: Свойство, означающее, что алгоритм состоит из конечного числа инструкций.
По вертикали 6: Одно из действий алгоритма.
По горизонтали 7: Последовательность действий, обладающая определенными свойствами
По горизонтали 8: Графическая форма записи алгоритма
По горизонтали 9: Свойство алгоритма, означающее, что последовательность инструкций предназначена для решения целого класса задач.
По горизонтали 10: Свойство алгоритма, означающее, что последовательность действий является понятной исполнителю.............

на завод по сбору ноутбуков поставляют комплектующие в том числе поставляют корпуса четырех различных цветов(черного,серебристого,коричневого,и белого) и к

лавиатурные модули таких же цветов при сборке ноутбука цвет корпуса не обязательно должен соответствовать цвету клавиатуры.Сколько различных цветовых решений ноутбуков могут получить на заводе ? А)4 Б)8 В)12 Г)16

Помогите найти возраст девочки!Ей было 1100 лет,Она в 101-й класс ходила,В портфеле по 100 книг носила -Все это правда, а не бред.* Когда

пыля десятком ног,Она шагала по дороге,За ней всегда бежал щенок*С одним хвостом, зато 100-ногий.Она ловила каждый звукСвоими десятью ушами,И 10 загорелых рукПортфель и поводок держали.И 10 темно-синих глазРассматривали мир привычно.....Но станет все совсем обычным,Когда поймете наш рассказ.



Вы находитесь на странице вопроса "Решение по С++", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.