Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С помощью паскаля!

5-9 класс


1. Задано x.
Вычислить у(1 картинка):

Belchonok2507 15 сент. 2015 г., 15:54:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Valerastronski
15 сент. 2015 г., 18:34:47 (8 лет назад)

1)
var x,y:real;
begin
write('Введите число ');
readln(x);
if x<3 then y:=x*x-5;
if (x>=3) and (x<=7) then y:=x;
if x>7 then y:=x-3;
writeln(y)
end.

2)
var x,y,s,p:real;
begin
readln(x,y);
s:=(x+y)/2;
p:=2*x*y;
if x<y then  
   begin   
      x:=s;
      y:=p
      end
   else
      begin
         y:=s;
         x:=p
         end;
writeln('x=',x,'; y=',y)
end.

3)
var 
   a,b,s:real;
   sim:char;
   f:boolean;
Begin
f:=true;
writeln('Введите два числа');
readln(a,b);
writeln('Введите знак операции');
readln(sim);
case sim of
   '+': s:=a+b;
   '-': s:=a-b;
   '*': s:=a*b;
   '/': s:=a/b
   else f:=false
   end;
if f then writeln ('результат ',a,sim,b,' = ',s) 
   else writeln('Введена некорректная арифметическая операция')
End.

4)

Ответить

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.



Вы находитесь на странице вопроса "С помощью паскаля!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.