Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Паскаль, ввести трёхзначное число

5-9 класс

если сумма цифр числа чётная, то увеличить на 2, в противном случае уменьшить на 2

Viktoria765 02 дек. 2015 г., 3:27:46 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fatima72
02 дек. 2015 г., 6:18:05 (8 лет назад)

Program I_have_got_name;
var   a:integer;
begin 
  write('Введите целое число'); 
  readln(a); 
  if ((a mod 10)+(a mod 100 div 10)+(a div 100)) mod 2 = 0 then     
     writeln(a+2) else     
          Writeln(a-2);
end.

Ответить

Другие вопросы из категории

Читайте также

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

Очень надо!! пожалуйста)Составить программу на языке Pascal, которая позволяет ввести с клавиатуры целое трехзначное число, проверяет, симметрично ли оно,

и печатает сообщение на экране. (Трёхзначное число симметрично, если крайние цифры числа одинаковые)

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"



Вы находитесь на странице вопроса "Паскаль, ввести трёхзначное число", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.