Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите,пожалуйста,написать программу в Паскале... Дан массив. Уменьшить все его элементы на число a.

10-11 класс

Yuliyaarhipova1 15 авг. 2013 г., 13:14:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Diawechka
15 авг. 2013 г., 15:22:36 (10 лет назад)

Program pr;
uses crt;
Var M:array[1..10, 1..15] of integer;
    i,j:integer;
    a:integer;
    
Begin
Writeln('vvedite a');
readln(a);
Writeln('vvedite massiv');
for i:=1 to 10 do Begin
    for j:=1 to 15 do read(M[i,j]);
                Writeln;
                end;


    for i:=1 to 10 do
        for j:=1 to 15 do M[i,j]:=M[i,j]-a;
        
    for i:=1 to 10 do Begin
        for j:=1 to 15 do Write(M[i,j]:5);
                       Writeln;
                       end;
        readln;
        end.

Ответить

Другие вопросы из категории

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

помогите пожалуйста решить! ( паскаль )

Паша (p) купил 10 яблок, а Коля k яблок.


Известно, что Коля купил больше яблок, чем Паша.


На сколько (x) яблок Коля купил больше, чем Паша?




Исходные данные: k


Результат: x


Пример 1: для исходных данных: 15 должен быть результат: 5


Пример 2: для исходных данных:10 должен быть результат: 0

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите пожалуйста...Напечатать программу в паскале...Срочно...Завтра последний срок сдачи..

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Помогите,пожалуйста,написать программу в Паскале... Дан массив. Уменьшить все его элементы на число a.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.