Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Написал программу, выдает массу ошибок, помогите найти пожалуйста

10-11 класс

var
a,f, power: real;

begin
if(pow(a,2)-sin(a)<3){
f=pow(a,3)-abs(20-pow(a,2));
}
then if(pow(a,2)-sin(a))=3 then{
f=abs(a-6);
}
else if(powwe(a,2)-sin(a)>3){
f=(a-1)/(10-pow(a,2);
}
then{
cout<<"Err"< }
end.

Amiragliulin 11 янв. 2015 г., 2:12:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vvalensia
11 янв. 2015 г., 4:43:23 (9 лет назад)

uses crt;
var a,f: integer;
begin
readln(a);
if((sqr(a)-sin(a))<3) then
f=pow(a,3)-abs(20-sqr(a));
if((sqr(a)-sin(a))=3) then
f=abs(a-6);
if((sqr(a)-sin(a))>3) then
f=(a-1)/(10-sqr(a));
writeln(f);
end.
P.S При чем тут С++ и Pascal?

+ 0 -
Kolan20021
11 янв. 2015 г., 6:00:12 (9 лет назад)

Смесь Паскаля и С++

Ответить

Другие вопросы из категории

Объем сообщения, содержащего 256 символов, составил 1/16 часть Кбайта.

Каков размер алфавита, с помощью которого записано сообщение?

Дан текст, в котором имеются цифры.Дан текст, в котором имеются цифры. Найти их сумму. Найти максимальную цифру

На языке програмирования! Паскаль АВС........
Плиз помогите , срочно нужно
Текст вводить с помошью readln. Он может содержать и буквы.
Одной программой

Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите пожалуйста,1. Дан символ. Написать программу, выводящую его код.

2. Дан код символа. Написать программу, выводящую сам символ.
3. Написать программу для вывода на экран всех маленьких латинских букв.



Вы находитесь на странице вопроса "Написал программу, выдает массу ошибок, помогите найти пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.