Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, составить программу, которая вычисляет значение Z =XY, где Y= SinX + 0.5. В случае Y=0 вывести на печать сообщение "Деление на 0".

10-11 класс

Gliuza71 22 янв. 2017 г., 21:09:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
HzChoPridymat
22 янв. 2017 г., 23:14:44 (7 лет назад)

program n1;
var x,y,z,s:integer;
begin
writeln('Vvedite x');
readln(x);
y:=sin(x)+0,5;
if (y<>0) then
begin
 z:=x*y;
writeln('z=',z);
end 
else
writeln ('delenie na 0'); 
end.

Ответить

Другие вопросы из категории

автоматическое устройство осуществило перекодировку информационного сообщения на русском языке длиной в 24 символов, первоначально записанного в 8-битной

кодировке КОИ-8, в 2-байтную кодировку Unicode. На сколько бит увеличилась длина сообщения?

101010100 решите пожалуйста)!
В некоторой стране автомобильный номер длиной 6 символов составляется из заглавных букв (всего используется 12 букв) и десятичных цифр в любом порядке.

Каждый символ кодируется одинаковым и минимально возможным количеством бит, а каждый номер – одинаковым и минимально возможным количеством байт. Определите объем памяти (в байтах), необходимый для хранения 15 автомобильных номеров.

Читайте также

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1)написать программу, которая вычисляет произведение сумм всех соседних пар целых чисел из диапазона от 12 до 36 и выводит значения тех сумм, которые

меньше 52.

2)В результате работы некоторой подпрограммы вычислены значения четырех переменных a, b, c, d. Написать на предложенном в пункте а) языке программирования программу, после работы которой в случае, если сумма положительных значений (среди a, b, c, d) больше 20, значение g равно наибольшему из a, b, c, а в остальных случаях значение g равно значению d. (В программе можно использовать новые переменные.)



Вы находитесь на странице вопроса "Помогите, составить программу, которая вычисляет значение Z =XY, где Y= SinX + 0.5. В случае Y=0 вывести на печать сообщение "Деление на 0".", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.