Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

РЕБЯТ ПОЖАЛУЙСТА ОЧЕНЬ НА ЗАВТРА НАДОООО!!! Напишите программу, которая определяет полиндром четырехзначное число или нет. Можно в Паскале плиз!

5-9 класс

Льоолька 01 апр. 2015 г., 20:23:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chemistercat
01 апр. 2015 г., 21:07:28 (9 лет назад)

var n:integer;

BEGIN

  read(n);

  if (n > 9999 or n<1000) then

    writeln('Вы дурак')

  else  begin

     if (n mod 10 = n div 1000 and n mod 100 div 10 = n div 100 mod 10) then

        writeln('Полиндром')

     else writeln('Нет');

  end;

END.

Ответить

Другие вопросы из категории

1. Сегодня у Пети и Коли новая игра: Коля задумывает правило преобразования числовой информации. Задача Пети — отгадать это правило. Ниже приведены

вопросы Пети и ответы Коли в нескольких таких играх. Попробуйте отгадать, какое правило задумал Коля в каждой игре. Вопросы и ответы Правило преобразования 1→ 2; 2→3; 3→4; 10→11; 100→101 1→2; 2→4; 3→6; 4→8; 10→20; 100→200 1→3; 2→5; 3→7; 4→9; 10→21; 100→201 1→2; 2→1; 3→4; 4→3; 10→9; 11→12; 100→99 1→2; 2→1; 3→6; 4→2; 10→5; 11→22; 100→50 1→1; 2→1; 3→1; 4→1; 10→2; 11→2; 100→3 ■ 1→1; 2→2; 3→0; 4→1; 20→2; 21→ 0

как жизнь ??? ))))))))))))

Читайте также

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Помогите пожалуйста. программа Паскаль дано трехзначное число. Напишите программу, которая определяет: является ли число перевертышем, т.е числом,

десятичная запись которого читается одинаково слева направо и справа налево Пример входных данных: 122, 121, 222 Пример выходных данных: нет, перевертыш, перевертыш



Вы находитесь на странице вопроса "РЕБЯТ ПОЖАЛУЙСТА ОЧЕНЬ НА ЗАВТРА НАДОООО!!! Напишите программу, которая определяет полиндром четырехзначное число или нет. Можно в Паскале плиз!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.