Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу в Free Pascal: Дано целое число неизвестной размерности. Найти сумму цифр его составляющих.

10-11 класс

PollyKoko 21 дек. 2014 г., 7:06:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinaadila
21 дек. 2014 г., 7:38:28 (9 лет назад)

var n,sum:integer;
begin
  sum:=0;
  write ('N = ');
  readln (n);
  while n <> 0 do
    begin
      sum:=sum+n mod 10;
      n:=n div 10;
    end;
  writeln ('Summa: ',sum);
end.

Ответить

Другие вопросы из категории

Помогите Пожалуйста решить. Для каждого студента группы из

15 человек известны оценки, полученные на пяти экзаменах сессии. Сформировать
столбец начисление стипендии исходя из среднего балла:=5 стипендия
повышена на 50%, от 4 до 5 – на 25%, менее 3,5 баллов – стипендия не начисляется.
Во всех остальных случаях начисляется базовая сумма/

Программное обеспечение на языке Qbasic .

Задача
Известно число А. Оно получено после того , как в числе В поменяли местами цифры в разряде сотен и единиц . Найдите число В

Читайте также

Написать программу в free pascal дан массив из 10элеметов найти

А)сумму элементов массива
Б)количество отрицательных элеметов
В)вывести номера элементов массива кратных 3

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль



Вы находитесь на странице вопроса "Написать программу в Free Pascal: Дано целое число неизвестной размерности. Найти сумму цифр его составляющих.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.