Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Написать программу в паскаль "найти сумму цифр сколь угодно значного целого числа". Использовать string

10-11 класс

Lena2509 29 авг. 2016 г., 12:02:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Razumovskaia041
29 авг. 2016 г., 13:09:19 (7 лет назад)

var  x:string; 
      i,s:integer;
BEGIN
s:=0;
readln(x);
for i:=1 to length(x) do  s:=s+StrToInt(x[i]);
writeln(s)
END.

+ 0 -
Esafiulina
29 авг. 2016 г., 15:20:04 (7 лет назад)

Решай сама,у нас самостоялка!

Ответить

Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу



Вы находитесь на странице вопроса "Написать программу в паскаль "найти сумму цифр сколь угодно значного целого числа". Использовать string", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.