Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заданы значения x y z Составить программу которая находит среднее арифметическое и среднее геометрическое этих чисел

5-9 класс

Moooojut 31 янв. 2017 г., 9:02:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nekitosina12
31 янв. 2017 г., 11:47:26 (7 лет назад)

Program Pr1;
uses crt;
var x,y,z:integer;
a:real;
Begin
clrscr;
readln(x,y,z);
a:=(x+y+z)/3;
writeln(a:8:3);
a:=exp(1/3*ln(x*y*z));
writeln(a:8:3);
end.

Ответить

Читайте также

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "Заданы значения x y z Составить программу которая находит среднее арифметическое и среднее геометрическое этих чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.