Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

10-11 класс

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Sasisasi 11 окт. 2013 г., 9:22:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
юльчешка
11 окт. 2013 г., 11:39:07 (10 лет назад)

const   
 n = 5; 
var   
a,b : array [1..n] of integer;   
i,s,k1,k2,max,min : integer;    


begin 
for i := 1 to n do   
readln (a[i]);    
for i := 1 to n do   
writeln (i,')elem = ',a[i]);    
end.  

begin 
for i := 1 to n do   
a[i] := i * 3;    
for i := 1 to n do   
writeln (i,')elem = ',a[i]); 
end.  

begin 
s := 0; 
for i := 1 to n do   
begin   
readln (a[i]);   
s := s + a[i];   
end;     
writeln (s);
end. 

begin   
k1 := 0;
k2 := 0;    
for i := 1 to n do   
begin   
readln (a[i]);   
if a[i] > 0 then     
k1 := k1 +1;   
if a[i] < 0 then     
k2 := k2 +1;   
end;       
writeln ('+ ',k1);   
writeln ('- ',k2); 
end.

 begin 
k1 := 0;
k2 := 0;  
 for i := 1 to n do   
begin   
readln (a[i]);   
if (a[i] > 0) and (i mod 2 = 1) then
     k1 := k1 +1;
    if (a[i] < 0) and (i mod 2 = 0) then     
k2 := k2 +1;   
end;      
writeln ('+ ',k1);
writeln ('- ',k2);
 end.  


begin 
for i := 1 to n do   
begin   
readln (a[i]);   
if a[i] < 0 then     
b[i] := sqr (a[i]);   
if a[i] > 0 then     
b[i] := a[i] * a[i] * a[i];   
end;    
 for i := 1 to n do 
 write (a[i],' '); 
writeln (); 
for i := 1 to n do   
write (b[i],' '); 
end.   

begin 
for i := 1 to n do   
readln (a[i]);
max := a[1]; min := a[1];
for i := 2 to n do
   begin   
if a[i] > max then     
max := a[i];   
if a[i] < min then     
min := a[i];   
end; 
writeln ('max=',max); 
 writeln ('min=',min); 
end.   

begin 
for i := 1 to n do   
readln (a[i]);    
writeln ('found :'); 
readln (s);   
 k1 := 0; k2 := 0; 
for i := n downto 1 do   
if a[i] = s then   
begin     
k1 := k1 + 1;     
k2 := i;   
end; 
writeln ('k=',k1); 
writeln ('i=',k2); 
   end.

Бери те переменные, которые используются в конкретной программме.

Ответить

Другие вопросы из категории

Для каждого числа от 1 до n определить,

является ли оно простым.
C++

Помогите пожалуйста. Нужно решить через программу Pascal ABC

Определить объем цилиндра и площадь его полной поверхности, если известны радиус основания и высота цилиндра.

Формулы:

Составить программу на паскаль.

Слова могут содержать любые символы языка.

Читайте также

РЕШИТЕ ПОЖАЛУЙСТА ТРИ ЗАДАЧИ 1)Вывести на экран число симметричное в веденному двухзначному число. 2)Вывести на экран

результат сравнения двух чисел.

3)Вести линейный массив и вычислить сумму всех элементов этого массива.

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.



Вы находитесь на странице вопроса "1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.