Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите, пожалуйста! Мне надо подробное решение.

10-11 класс

На вход программе подается
последовательность символов, заканчивающаяся точкой. Требуется написать
программу, которая определяет, есть ли в этой последовательности десятичные
цифры, и выводит наибольшее число, которое можно составить из этих цифр.
Ведущих нулей в числе быть не должно (за исключением числа 0, запись которого
содержит ровно одну цифру). Если цифр нет, программа должна вывести на экран
слово «Нет», а если есть – слово «Да» и в следующей строчке искомое число.
Например, если исходная последовательность была такая:

Day 10, mice 8: "Year" 7 is a mistake 91.

GvOzDandJAM 20 дек. 2013 г., 14:26:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasha5554
20 дек. 2013 г., 15:04:56 (10 лет назад)

var
  str, num: string;

begin
  readln(str); //str := 'Day 10, mice 8: "Year" 7 is a mistake 91.';
  foreach c: char in str do
    if (Char.IsDigit(c)) then
      num += c;
  for j: byte := 1 to length(num) - 2 do
    for i: byte := 1 to length(num) - 1 do
      if (num[i] < num[i + 1]) then
      begin
        str[1] := num[i];
        num[i] := num[i + 1];
        num[i + 1] := str[1];
      end;
  if (Integer.Parse(num) > 0) then
  begin
    while (num[num.Length - 1] = '0') do
      num.Remove(num.Length - 1);
    writeln('Да' + #13 + num);
  end
  else
    writeln('Нет');
end.

Ответить

Другие вопросы из категории

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Помогите, пожалуйста! Мне надо подробное решение.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.