Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите плиз

10-11 класс

Задан массив Х(50). Переписать в массив У элементы массива Х в обратном порядке

вадим19032004 28 авг. 2014 г., 19:44:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimadmit
28 авг. 2014 г., 21:27:24 (9 лет назад)

var
   x, y: array [1..50] of integer;
   i: integer;
begin
     for i := 1 to 50 do
         x[i] := random(50);
     for i := 1 to 50 do
         y[i] := x[51 - i];
     for i := 1 to 50 do
          writeln('x[', i, '] => ', x[i]);
     for i := 1 to 50 do
          writeln('y[', i, '] => ', y[i]);
end.

Вот, циклы объединять не стал, т.к. они всё-таки разные дела делают:)

Ответить

Другие вопросы из категории

Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи,задавая комбинацию точек и тире.Сколько различных символов(цифр,букв,знаков

пунктуации и т.д)можно закодировать,используя код Морзе длиной ровно в пять сигналов(точек и тире)?напишите по подробнее

Прошу помочь,задание легкое но спать хочу,не шарю. Определите значение переменной "с" после выполнения следующего фрагмента программы: а :=

100

b := -50

а := а - b * 3

если а > b то с := а - b

иначе с := b - а

всё

Варианты ответов: 1)с=0 , 2)с= - 300 , с=250 , 4)с=400

На логику. Помогите пожалуйста.

10 кл
срочно нужно

Читайте также

Помогите плиз решить ничего не понимаю заранее спасибо

1.Сколько раз будет выполнена команда повторения в приведенных фрагментах при n=7:
1) for i :=n downto 4 do;
2)S:=S * i.
2. Определите, какой будет результат приведенного фрагмента: a:=100, n:=4:
for i:=1 to n do
a:=a - 2 * i.
Очень важно помогите.

Помогите плиииз=)

Привет. Помогите плиз=)
№1)Составить алгоритм вывода среднего(не арифметического) из трёх чисел в виде блок-схемы.
Входные данные:три числа
Выходные данные:среднее число

№2) На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

помогите плиз сделать 2,3,4)))


Вы находитесь на странице вопроса "Помогите плиз", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.