Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дано словесное описание алгоритма: z:=2; d:=7; k=0; Начало цикла пока d>=z

5-9 класс

d:=d – z; k=k+1;

конец цикла;

Вывести результат на экран.

Составить блок-схему в виде циклического алгоритма. Определить количество циклов k. Написать программу на языке Паскаль с использованием оператора цикла с предусловием.

BOGOSLAVEYS1973 17 дек. 2013 г., 16:24:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dosha02
17 дек. 2013 г., 19:02:32 (10 лет назад)

program first;

var z,d,k:integer;

begin

writeln('Input z,d,k');

readln(z,d,k);

if (d>=z) then

d:=d-z

k:=k+1

writeln(d,'   ',k);

readln;

end.

+ 0 -
Koma123
17 дек. 2013 г., 20:47:03 (10 лет назад)

program xxx;

   var z,d,k : integer;

begin

  z:=2; d:=7; k:=0;

  while (d>=z) do

    begin

      d:=d-z;

      k:=k+1

    end;

  writeln(d,'   ',k);

  readln

end.

 

Ответить

Другие вопросы из категории

Читайте также

Выполнить по словесному описанию алгоритм:

1. берем число 17
2. повторяем 3 раза
делать
3. увеличиваем полученное число в два раза
4. увеличиваем полученное число на 31
конец цикла
5. записываем ответ

Помогите решить (в ответе 353)

Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке

применить описанный алгоритм дважды (т.е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)?

Некоторый алгоритм из одной цепочки десятичных цифр получает новую цепочку следующим образом: 1. первая цифра исходной цепочки не

меняется; 2. каждая следующая цифра (начиная со второй) заменяется суммой этой цифры и предыдущей цифры исходной цепочки. Сумма вычисляется до тех пор, пока не будит получена десятичная цифра. Например, сумма цифр 7 и 5 равна 12. Это число, а не десятичная цифра, значит, необходимо суммирование продолжить: 1+2=3. Это цифра, следовательно, суммирование закончено. Например, если исходная цепочка 4 7 2 8 1, то результатом работы этого алгоритма будет цепочка 4 2 9 1 9. Дана цепочка символов 1 7 5 2 6 .применить к этой цепочке описанный алгоритм дважды. какая цифра чаще всего встречается в получившейся цепочке?

Дан следующий алгоритм (символом := обозначается операция присваивания): Ввести a, b

a:=a+b

b:=a-b

a:=a-b

Вывести a+b

Расположите исходные данные для этого алгоритма в порядке ВОЗРАСТАНИЯ результатов.

1) a=10 , b=8

2) a=4 , b=12

3) a=7 , b=7

4) a=6 , b=9

5) a=9 , b=11

Помогите, пожалуйста! Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки

символов; если она четна, то в конец цепочки символов добавляется символ О, а если нечетна, то в начало цепочки добавляется символ А. В полученной цепочке символов каждая буква заменяется буквой, предшествующей ей в русском алфавите(Б- на А, В-на Б и тд, а А на Я) Затем цепочка переписывается с конца к началу. Получившаяся таким образом цепочка является результатом работы алгоритма.
Дана цепочка символов ВПУ. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды(т.е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)? если можно объясните, пожалуйста:)



Вы находитесь на странице вопроса "Дано словесное описание алгоритма: z:=2; d:=7; k=0; Начало цикла пока d>=z", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.