Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива

5-9 класс

таким образом, что производится перестановка 6 и 16 элементов массива

Selenakotova 08 нояб. 2014 г., 13:39:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
русьхлеб
08 нояб. 2014 г., 14:58:54 (9 лет назад)

program z1;

var

a:array [1..20] of integer;

b,i:integer;

begin
b:=0;
for i:= 1 to 20 do

a[i]:=random(30)-15;

for i:= 1 to 20 do

write(a[i]);

writeln;
b:=a[6];
a[6]:=a[16];
a[16]:=b;
write(a[i]);

end.

Ответить

Другие вопросы из категории

-Задумайте 3 разных, произвольных чисел.

-Прибавьте к ним 25.
-К ответу прибавьте ещё 125.
-Из ответа вычтите 36
-Из ответа вычтите эти задуманные числа.
-Ответ умножьте на 5.
-ответ разделите на 2.
ПОжалуйста помогите. Мне срочно надо

Помогите построить алгоритм к этому уравнению! y=x+5

Заранее спасибо.

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.



Вы находитесь на странице вопроса "Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.