Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

1) Создайте массив записей, содержащий сведения об альбомах различных групп:

10-11 класс

название группы;
название альбома;
год выпуска;
стиль.
Выведите на экран все альбомы в стиле pop и rock.

2) Преобразовать одномерный массив вещественных чисел, присвоив каждому элементу квадрат его значения.



валет13 17 окт. 2013 г., 10:33:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slava270499
17 окт. 2013 г., 11:11:15 (10 лет назад)

Задание 1 во вложении.

Задание2.

const
  m = 20;{максимальное количество элементов}

var
  a: array[1..m] of real;
  i, n: integer;

begin
  Write('Введите количество элементов (от 1 до 20): ');
  Readln(n);
  Writeln('Вводите через пробел элементы массива');
  for i := 1 to n do
  begin
    Read(a[i]);
    a[i] := sqr(a[i])
  end;
  Writeln('Результирующий массив:');
  for i := 1 to n do Write(a[i]:0:4, ' ');
  Writeln
end.

Тестовое решение:

Введите количество элементов (от 1 до 20): 5
Вводите через пробел элементы массива
1.3 2.7 -4 4.23 0
Результирующий массив:
1.6900 7.2900 16.0000 17.8929 0.0000


+ 0 -
Artyrkitoyan199
17 окт. 2013 г., 13:34:32 (10 лет назад)

Это на чем писать?

+ 0 -
Deltafobos
17 окт. 2013 г., 14:51:24 (10 лет назад)

паскаль вроде

+ 0 -
Svet331blk
17 окт. 2013 г., 16:25:17 (10 лет назад)

ВРОДЕ??? Т.е. я, к примеру, буду это писать полчаса, а потом Вы напишете "Извините, я ошиблась, Бейсик (Aceess, C++, Excel и тп)" ?

+ 0 -
ННастяН
17 окт. 2013 г., 18:21:32 (10 лет назад)

Пасибочки за задания=)

+ 0 -
375336415145
17 окт. 2013 г., 19:43:12 (10 лет назад)

"Пасибочки" кнопочкой выражаются, а звездочками рядом - их размер.

Ответить

Другие вопросы из категории

Напишите соотношение:

1)Кбит/с к бит/с
2)Мбит/с к бит/с
3)Гбит/с к бит/с

Составить блок-схему и

указать тип алгоритмов:Найти сумму первых десяти натуральных четных чисел.

Ввести одномерный массив A , вывести его. Найти произведение

элементов стоящих слева и справа от минимального элемента массива.
Разделить на найденное произведение минимум и максимум. Изменённый
массив вывести.
Вот начало:

program ABC;
const Nmass=100;
var A:array[1..Nmass] of integer;
N,i,k,max,min: byte;
buf:integer;
begin
cls;
//ручной ввод массива
writeLn('Введите число элементов в массиве A');
readLn(N);
writeLn('Вводим элементы массива A:');
for i:=1 to N do
begin
write('A[',i,']=');
readLn(A[i]);
end;
//вывод массива до измененния
writeLn('Исходный массив A:');
for i:=1 to N do
write(A[i]:5);
writeLn;


Читайте также

В школьной базе данных хранятся записи, содержащие информацию об учениках :<Фамилия>- 15 символов: русские буквы(первая прописная, остальные

строчные)
<Имя>- 12 символов: русские буквы(первая прописная, остальные строчные)
<Отчество>- 15 символов: русские буквы(первая прописная, остальные строчные)
<Год рождения>- числа от 1992 до 1999
Каждое поле записывается с использованием минимально возможного кол-ва бит. Определить минимальное кол-во байт, необходимое для кодирования одной записи, если буквы е и ё считаются совпадающими.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.

Помогите люди добрые!!! Задание для VBA

Пусть дан массив, содержащий сведения об игрушках: указывается название игрушки (например, кукла, кубики, мяч, конструктор и т. д.), ее стоимость копейках и возрастные границы детей, для которых игрушка предназначена (например, для детей от 2 до 5 лет). Получите информацию:
а) о названиях игрушек, цена которых не превышает 4 рублей и которые
подходят детям до 5 лет;
b) о цене самого дорогого конструктора;
с) о названиях наиболее дорогих игрушек (цена которых отличается от цены
самой дорогой игрушки не более, чем на 1 рубль);



Вы находитесь на странице вопроса "1) Создайте массив записей, содержащий сведения об альбомах различных групп:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.