Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

10-11 класс

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

Mariaqw 14 янв. 2014 г., 17:27:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
EvelinkaMalinka
14 янв. 2014 г., 18:38:53 (10 лет назад)


var i,max:integer; fio:string; x:array[1..5] of integer;
    F1,F2:text;
begin
 assign(F1, 'out.txt'); assign(F2, 'out2.txt');
 rewrite(F1); rewrite(F2);
 for i:=1 to 5 do
   begin
     writeln('daite FIO ',i,'-ogo rabotnika'); readln(fio);
     writeln('daite otklad rabotnika ',i); readln(x[i]);
     writeln(F1, i,' ',fio,' ',x[i]); fio:='';
   end;
   max:=x[1];
   for i:=1 to 5 do if x[i]>max then max:=x[i];
   writeln(F2, max);  close(F1); close(F2);
 readln;
end.

 

rabotatet! proveril v PASCALE

Ответить

Другие вопросы из категории

Сформировать двумерный массив M(3,4) чисел 22,3,5,7,12,15,17,8,9,1,23,45; Вывести на экран в виде таблицы; Найти максимальные и минимальные значения .

Заменить элементы первой строки на нули. ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ НАДО!!!!!

Дана последовательность

не более N
ненулевых целых чисел, последним числом в последовательности является
0. Ввести эту последовательность в одномерный массив и
вычислить хаpактеристики
.Найти порядковые номера и сумму двух наибольших элементов. ( в Паскаль )

1) Создайте массив записей, содержащий сведения об альбомах различных групп:

название группы;
название альбома;
год выпуска;
стиль.
Выведите на экран все альбомы в стиле pop и rock.

2) Преобразовать одномерный массив вещественных чисел, присвоив каждому элементу квадрат его значения.



Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

34 балла.Решите задачу в pascal abc.


Вы находитесь на странице вопроса "Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.