Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Для каждого четырёхзначного числа из диапазона от A до B включительно

5-9 класс

( A<B)требуется найти произведение средних разрядов (сотни, десятки), и вычислить сумму этих произведений.

Vim20007 06 марта 2014 г., 1:45:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Boxxymila007
06 марта 2014 г., 3:36:22 (10 лет назад)

Program enot;
Var i,a,b,n,f,g,v,p,s,c,j:integer;
x: array[1..9999] of integer;
begin
read(a,b);
n:=b-a+1;
for i:= a to b do
begin
x[i]:=i;
for j:= a to b do
 begin
c:=j div 10;
V:=c mod 10;
f:=c div 10;
G:= f mod 10;
p:= v*g;
end;
s:=s+p;
end;
writeln(s);
end.

+ 0 -
7548290
06 марта 2014 г., 4:45:31 (10 лет назад)

с помощью какой проги выполнять?

+ 0 -
89263380141
06 марта 2014 г., 6:59:38 (10 лет назад)

pascal

+ 0 -
пупсяяяшик
06 марта 2014 г., 8:30:33 (10 лет назад)

ты точно полностью написал условие?

+ 0 -
виктория1661
06 марта 2014 г., 9:30:21 (10 лет назад)

Для каждого четырёхзначного числа из диапазона от A до B включительно (A<B) требуется найти призведение средних разрядов (сотни, десятки), и вычислить сумму этих произведений.

Например, если на вход программы подать A=1234 и B=1236, должно быть выведено 18.

Ответить

Другие вопросы из категории

в чашке стакане кувшине и банке находятся молоко, лимонад, квас и вода. известно, что вода и молоко не в чашке; сосуд с лимонадом стоит между кувшином

и сосудом с квасом. в банке не лимонад и не вода, а стакан стоит между банкой и сосудом с молоком. где находится квас?

год создания первого компьютера, год создания первого отечественного компьютера, год открытия радиосвязи, год первого полета человека, год принятия

христианства на руси, год первого упоминания в летописи о москве, год начала великой отечественной войны, год запуска первого искусственного спутника земли, год открытия колумбом америки.

Читайте также

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.



Вы находитесь на странице вопроса "Для каждого четырёхзначного числа из диапазона от A до B включительно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.