Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Напечатать последовательность чисел Фибоначчи 1, 1, 2, 3, 5 ... и т.д., где каждое число равно сумме двух предыдущих: ровно N чисел.

10-11 класс

Маркелов67 15 нояб. 2015 г., 10:56:36 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Марусяваф
15 нояб. 2015 г., 12:21:09 (8 лет назад)

Program Fibonacci;
Uses Crt;
var i, n:integer;
{Итерационный метод вычисления чисел Фибоначчи}
function fib_it(n:integer):integer;
var a,b,c,i:integer;
begin
a:=1;b:=1;
if (n=1) or (n=2) then fib_it:=1
else begin
            for i:=3 to n do 
                 begin
                   c:=a+b
                   a:=b;
                 b:=c; 
               end;  
     fib_it:=c;
   end;  

end;

{main program}
begin
    clrscr;
    write('Введите n: ');
   readln(n);
    for i:=1 to n do write(fib_it(i),' '); 
     readkey;
end.





+ 0 -
саша002агент
15 нояб. 2015 г., 14:41:47 (8 лет назад)

Program Fibonacci;
var
  p, q, r, i, n: integer;
begin
  write('Alphaeus asks: please enter n = ');
  readln(n);
  p := 1;
  writeln(p);
  q := 1;
  writeln(q);
  for i:=3 to n do begin
    r := p+q;
    writeln(r);
    p := q;
    q := r
  end;
end.

Ответить

Другие вопросы из категории

Помогите написать программу.

Очень срочно надо.

ОЧЕНЬ СРОЧНО НУЖНО написать программу на С++. Идет n-я секунда суток. Определить, сколько полных часов и полных минут прошло до этого момента. +

Отформатировать исходный код программы. + Определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений

Напишите программу в паскале абс.

С клавиатуры вводятся целые числа a, b и c. Вычислите значение
следующего выражения

где

Система КуМир нужно:

Составить цикл (для, пока и кц при).

1) Составьте программу, которая вычисляет среднее
арифметическое положительных и четных чисел из N введенных. Значение N вводится с клавиатуры.

Читайте также

Числа Фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765,

…, в которой каждое последующее число равно сумме двух предыдущих чисел. Количество простых чисел среди первых сорока пяти чисел Фибоначчи составляет …

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

Написать программу в Паскале. Последовательность фибоначчи образуется так:первый и второй члены равны 1,каждый следующий равен сумме двух

предыдущих(1,1,2,3,5,8,13,...)найти числа последовательности фибоначчи сумма которых меньше пятизначного числа n.



Вы находитесь на странице вопроса "Напечатать последовательность чисел Фибоначчи 1, 1, 2, 3, 5 ... и т.д., где каждое число равно сумме двух предыдущих: ровно N чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.