Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Турбо паскаль:

10-11 класс

for i:=2 to sqrt(n) do if (n mod i = 0) then prost:=0;

паскаль выдает ошибку 39 ( в выделеном месте
подскажите, пожалуйста как ее устранить

79044848282 23 нояб. 2015 г., 5:54:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Кристиночка555
23 нояб. 2015 г., 7:58:08 (8 лет назад)

Возможно у вас что то не так с типами. i должен быть longint, а не real... n должен быть real (вещественный),однако вы используете операцию n mod i, поэтому я вам могу посоветовать использовать N тип longint,но заменить sqrt(n) на round(sqrt(n)) round - это округление

Ответить

Другие вопросы из категории

Помогите написать программу.

Очень срочно надо.

ОЧЕНЬ СРОЧНО НУЖНО написать программу на С++. Идет n-я секунда суток. Определить, сколько полных часов и полных минут прошло до этого момента. +

Отформатировать исходный код программы. + Определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений

Напишите программу в паскале абс.

С клавиатуры вводятся целые числа a, b и c. Вычислите значение
следующего выражения

где

Читайте также

Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

Помогите, пожалуйста!!!

Составить программу на языке Турбо-Паскаль, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: Данные числа x, y являются координатами точки, лежащей в первой координатной четверти

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.

Как заменить программму в турбо паскале чтоб она решалась в паскале ABC? program kRUGI;

uses crt;
var gd,gm,c,i,r,x,y,n:integer;
begin
clrscr;
randomize;
writeln('введите колличество окружностей->');
readln(n);
gd:=0;
for i:=1 to n do begin
r:=random(80);x:=random(600);y:=random(400);
c:=random(15);setcolor(c);
circle(x,y,r);
setfillstyler(1,c);floodfill(x,y,c);
end;
readkey;
closegraph;
end.



Вы находитесь на странице вопроса "Турбо паскаль:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.