Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

ребят помогите программу на паскале для 7-ого задания сделать, заранее благодарю))

10-11 класс

Vika9911 05 янв. 2016 г., 22:21:47 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polina1PSS
06 янв. 2016 г., 0:47:32 (8 лет назад)

Program Task;
Const n = 6;
Var a: Array [1..n, 1..n] of Integer;
b: Array[1..n] of Integer;

i, j, k, first, last, sum1, sum2: Integer;
Begin
Randomize;
For i := 1 To n Do
For j := 1 To n Do
a[i, j] := Random(10);
WriteLn('Сформированный массив:');
For i := 1 To n Do
Begin
For j := 1 To n Do
Write(a[i, j], ' ');
WriteLn;
End;
first := 1;
last := n;
For i := 1 To n Do
If i <= (n Div 2) Then
Begin
For j := first To last Do
sum1 := sum1 + a[i, j];
first := first + 1;
last := last - 1;
End
Else
Begin
For j := first To last Do
sum2 := sum2 + a[i, j];
first := first - 1;
last := last + 1;
End;
If sum1 = sum2 Then
WriteLn('Суммы элементов равны')
Else
WriteLn('Суммы элементов не равны');
first := 1;
For k := 1 To n Do
Begin
j := 1;
For i := first To n Do
Begin
b[k] := b[k] + a[i, j];
j := j + 1;
End;
first := first + 1;
End;
WriteLn('Массив сумм элементов главной диагонали и каждой из диагоналей, лежащих ниже главной:');
For i := 1 To n Do
Write(b[i], ' ');
ReadLn;
End.

Ответить

Другие вопросы из категории

SOS

Ученики класса,состоящего из 24 человек,изучают немецкий или французский языки.Сообщение о том,что ученик изучает немецкий язык несёт 3 бита информации.Сколько человек изучает французский и немецкий языки?
Заранее спасибо)

Турбо паскаль:

for i:=2 to sqrt(n) do if (n mod i = 0) then prost:=0;

паскаль выдает ошибку 39 ( в выделеном месте
подскажите, пожалуйста как ее устранить

Помогите написать программу.

Очень срочно надо.

Читайте также

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "ребят помогите программу на паскале для 7-ого задания сделать, заранее благодарю))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.