Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся с клавиатуры. Результаты

10-11 класс

работы программы записываются в файл Out.txt.

Sayatsyraganov 06 июня 2016 г., 16:29:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Евгения20001
06 июня 2016 г., 18:49:49 (7 лет назад)

Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся из файла Input.txt. Результаты работы программы записываются в файл Out.txt. 
Вопрос в том что я написал программу: и вывел чтоб он считал сумму четных чисел а сумму считает не правильно 

вот программа: 

//---------------------------------------------------------------------------
#include <stdio.h> 
#include <conio.h> 
#include <math.h> 
//---------------------------------------------------------------------------
int main () 

FILE *f1, *f2; 
int n, i; 
float s; 
f1 = fopen("input.txt", "r"); 
f2 = fopen("out.txt", "w"); 
fscanf (f1, "%d", &n); 
for (i=1; i<=n; i++) 

if ((n>0) && (i%2==0)) 
fprintf(f2, "=", i); 

s=0; 

s=(float)s+i; 
fprintf(f2,"\n Summa=%f", s); 

fclose(f1); 
fclose(f2); 
getch(); 
return 0; 

//---------------------------------------------------------------------------

Ответить

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N – количество чисел) вводятся с клавиатуры. Результаты", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.