Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Поосгите решить 4 задачу, C++

10-11 класс

Noweq 25 дек. 2014 г., 1:11:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Press741
25 дек. 2014 г., 3:04:38 (9 лет назад)

#include <iostream>

using namespace std;

bool PrCh(int ch){   
  for (int i = 2; i <= ch / 2; i++){     
    if (ch % i == 0)           
    return false;   
}   
return true;}
int main (){   
int a;   
 cin >> a; 
  if (PrCh(a))   
    cout << "YES";   
 else       
 cout << "NO";   
return 0;
}

Ответить

Другие вопросы из категории

Найти сумму элементов,которые не равны 100,на главной диагонали массива a(5,5)

Создать алгоритм,нужен просто алгоритм

123 перевести из десятиричной в двоичную
40кбайт интернета это сколько
Задача на программе АВС паскаль:

Дано число, определите является ли оно двухзначным и кратным 2 и 6

P.S. должно решаться через мод

Читайте также

Две девочки и два мальчика из 2 Б. класса соревновались в умении решать задачи . Всего ребята решили 11 задач , причем все - разное количество . Кто решил

больше задач: мальчики или девочки ,если один мальчик решил больше всех ,а другой меньше всех ?

Приближается очередная олимпиада по программированию, и товарищи A и B решили устроить совместную тренировку. Они выбрали n задач и договорились,

что тренировка продлится t минут.Для каждой задачи известно время si (i = 1; 2; : : : ; n), которое потребуется на её решение. Уровень подготовки у товарищей A и B одинаковый, и если товарищ A решает некоторую задачу за время s, то и товарищ B решает эту задачу за это же время s.Товарищ A начал решать задачи с первой и будет решать их подряд, двигаясь от первой к последней и не пропуская ни одной. Товарищ B начал решать задачи с последней и тоже будетрешать их подряд, двигаясь от последней к первой и не пропуская ни одной.Ваша же задача — определить, сколько задач решат в течение тренировки товарищи A и B.В качестве ответа выведите два целых числа: количество задач, которые решит товарищ A, и через пробел — количество задач, которые решит товарищ B.

Формат входного файла

В первой строке содержатся через пробел два целых числа — n (1 n 100) и t (1 t 1000).
Во второй строке содержатся n целых чисел s1; s2; : : : sn (1 si 1000; i = 1; 2; : : : ; n), также отделённые друг от друга пробелом.

Формат выходного файла

В единственной строке выходного файла содержатся два целых числа через пробел — количество задач, которые решит товарищ A, и количество задач, которые решит товарищ B соответственно.

На Паскаль :)

Здравствуйте. Помогите решить эту задачу в Pascal:

Найти минимальный среди максимальных элементов каждого из столбцов матриц С(5,10) и D(10,20). Задачу решить с использованием подпрограммы.

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "Поосгите решить 4 задачу, C++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.