Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Выручите, пожалуйста! Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающий заданного натурального числа N. Проверьте алгоритм

5-9 класс

трассировкой. Напишите программу на Паскале.

Qwerty123987 25 дек. 2014 г., 18:29:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KsushaManul
25 дек. 2014 г., 21:29:01 (9 лет назад)

var N,  i, sum: longint;
begin
writeln('Введите число');
readln(N);
sum:=0;
for i:=1 to N-1 do
sum:= sum+i;
writeln(sum);
readln
end.
 Выбирайте лучший ;)

Ответить

Другие вопросы из категории

срочно подскажите мне!!!!

Дано целое число А. Если значение А > 0, то необходимо
увеличить его на единицу. Разработать схему алгоритма для решения этой
задачи. Протестировать алгоритм для A=5, A=-4, A=0. сделать в паскале.


Программу я написала:

Program n1;
var A: real;
begin
readln (a);
if a>0
then a:=a+1;
writeln;
end.


правильно или нет? и какие у меня должны выходить значения?

Читайте также

Составьте алгоритм вычисления суммы всех

натуральных чисел, не превышающих заданного натурального числа N.
Проверьте алгоритм трассировкой. Напишите программу на Паскале.

Помогите,пожалуйста..

Составите алгоритм вычисления суммы всех натуральных чисел,не превышающих заданного натурального числа N (на Паскале с циклом WHILE)



Вы находитесь на странице вопроса "Выручите, пожалуйста! Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающий заданного натурального числа N. Проверьте алгоритм", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.