Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите составить алгоритм решения(блок-схема) уравнения ax2+bx+c=0

10-11 класс

Очень срочно!

МaSьКa 14 нояб. 2013 г., 5:47:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastiya0145
14 нояб. 2013 г., 7:13:46 (10 лет назад)

var x1,x2,D:real;
a,b,c:integer;
begin
readln(a,b,c);
D:=sqr(b)-4*a*c;
x1:=(-b+sqrt(D))/(2*a);
x2:=(-b-sqrt(D))/(2*a);
writeln(x1,x2);
readln;
end.

Ответить

Другие вопросы из категории

Решите систему уравнений :

16y Мбайт = 8х бит

Какой из операторов цикла имеет 2 вида записи

For

While…

Repeat…

Верного ответа нет

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.



Вы находитесь на странице вопроса "Помогите составить алгоритм решения(блок-схема) уравнения ax2+bx+c=0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.