Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Локатор ориентирован на одну из сторон света ("С" — север, "З" — запад, "Ю" — юг, "В" — восток) и может принимать три цифровые команды: 1 — поворот

10-11 класс

налево, –1 — поворот направо, 2 — поворот на 180 градусов. Дан символ C — исходная ориентация локатора и числа N1 и N2 — две посланные ему команды. Вывести ориентацию локатора после выполнения данных команд. Написать программу на языке Паскаль

Danilzhaboedov 10 авг. 2015 г., 2:48:32 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1985anna
10 авг. 2015 г., 3:41:29 (8 лет назад)

const
  destinations = 'СЗЮВСЗЮВСЗЮВ';    {Предварительно сформированная строка ориентаций}
var
  C : char;
  N1, N2, Position : integer;
begin
  write('Исходная ориентация локатора: ');
  readln(C);
  write('Первая команда поворота: ');
  readln(N1);
  write('Вторая команда поворота: ');
  readln(N2);
  Position := Pos(C, destinations) + 4;   {Устанавливаем позицию на положение заданного направления}
  Position := Position + N1; {Направление после первого поворота (Определяется destinations[Pos])}
  Position := Position + N2; {Направление после второго поворота (Определяется destinations[Pos])}
  writeln('Конечная ориентация: ', destinations[Position]);
end.  

+ 0 -
Slebanp
10 авг. 2015 г., 5:32:41 (8 лет назад)

PascalABC.NET подойдёт?

Ответить

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

1) Сколько следует задать вопросов и как их следует формулировать, чтобы количественно оценить сообщение о том, что вагон стоит на одном из 16 путей?

2) Вы бросаете два кубика с нанесенными на гранях цифрами от 1 до 6. Определите, сколько битов информации несет сообщение о том, что на одном кубике выпала тройка, а на другом- пятерка.
3) Предположим, вероятность того, что вы получите за контрольную работу оценку "5", равна 0,6; вероятность получения "4" равна 0,3; вероятность получения "3"-0,1. Определите, сколько битов информации будет нести сообщение о результатах контрольной работы в каждом из вариантов. ПОЖАЛУЙСТА, ПОМОГИТЕ!!!

Если в сети с кольцевой структурой на одном из участков поврежден кабель, то ...

1) ...вся сеть в целом становится неработоспособной

2) ...нарушается связь только между ближайшими к повреждению компьютерами

3) ...нарушается связь только с одной из рабочих станций, все остальные сохраняют
работоспособность

4) ...сеть делится на две работоспособных части, однако связь между ними отсутствует

Если в сети с кольцевой структурой на одном из участков поврежден кабель, то ...

1) ...вся сеть в целом становится неработоспособной

2) ...нарушается связь только между ближайшими к повреждению компьютерами

3) ...нарушается связь только с одной из рабочих станций, все остальные сохраняют
работоспособность

4) ...сеть делится на две работоспособных части, однако связь между ними отсутствует

. В формировании цепочки из четырех бусин используются некоторые правила: В конце цепочки стоит одна из бусин Р, N, Т, O. На первом – одна из бусин P,

R, T, O, которой нет на третьем месте. На третьем месте – одна из бусин O, P, T, не стоящая в цепочке последней. Какие из перечисленных цепочек созданы с учетом этих правил? 1) PORT 2) TTTO 3)TTOO 4) OOPO 5) РТON 6) ONNO



Вы находитесь на странице вопроса "Локатор ориентирован на одну из сторон света ("С" — север, "З" — запад, "Ю" — юг, "В" — восток) и может принимать три цифровые команды: 1 — поворот", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.