Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Много баллов дам за решение..

5-9 класс

Треугольник задан координатами вершин, вычеслить периметр, площадь.вычеслить длин сторон, оформить с помощью процедур
задачу на Паскале
пожалуйста срочно надо

Dashiko2003 18 мая 2013 г., 0:47:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АндрейККК
18 мая 2013 г., 2:16:52 (10 лет назад)

program gt;
var x1,y1,x2,y2,x3,y3,a,b,c,p,s:real;
procedure dlinastoron(x1,y1,x2,y2:real;var b:real);
begin
b:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
end;
procedure perimetr(a,b,c:real;var d:real);
begin
d:=a+b+c;
end;
procedure ploshad(a,b,c:real;var d:real);
var s:real;begins:=(a+b+c)/2;
d:=sqrt(s*(s-a)*(s-b)*(s-c));
end;
begin
readln(x1,y1,x2,y2,x3,y3);
dlinastoron(x1,y1,x2,y2,a);
dlinastoron(x1,y1,x3,y3,b);
dlinastoron(x3,y3,x2,y2,c);
perimetr(a,b,c,p);
ploshad(a,b,c,s);
writeln(a,' ',b,' ',c);
writeln(p);
writeln(s);
end.

Ответить

Другие вопросы из категории

Дискретным называют сигнал:

а) принимающий конечное число определённых значений
б) непрерывно изменяющийся во времени
в) который можно декодировать
г) несущий какую-либо информацию

ПОВТОРЕНИЕ ПО ТЕМЕ «ГРАФИЧЕСКИЙ РЕДАКТОР» 1. Минимальным объектом в

графическом редакторе является:

№1

Скорость работы домашнего интернета составляет 2 мега байта в секунду.Расчитать, сколько времени понадобится для скачивания:фильма,размером 4 гига байта),игры размером 1 гегабайта 200 мегабайт.
№2
Вычислить инфармационный объём твоей тетради(48 листов),если за ёмкость клеточки брать 1 байт.
№3
Объём жёсткого диска компютера в школе составляет 500 гига байт.Вычислить количество программ,которые можно установить на компьютер,если принять размер 1 программы за 500 мега байт.

Умоляю решите!!!Даю 20 балов!!!

Составте алгоритм для определения количества цифр в записи числа произвольного натурального числа.

оооочень буду благодарна ! хочу понять!ПОМОГИТЕ МНЕ

Читайте также

Даю много баллов за решение!

написать программу по которой
найти минимальный и максимальный элемент массива и все элементы между ними заменить 0...(10,50)
Срочно

Люди,кто желает выполнить практическое задание за 8 класс ,очень срочно,поэтому даю много баллов! Вот задание!!!

Практическое задание

Открой
файл кр1-1.docx.
Выполни редактирование и форматирование текстового документа так, чтобы его вид
совпал с образцом текста, выданного учителем:

Решите задачу 9 класс. Срочно! Много баллов!

Достаточно ли видеопамяти объемом 256 кбайт для работы монитора в режиме 640х480 и палитрой из 16 цветов.
Оформить как задачу (Дано, решение, все формулы и т.п)



Вы находитесь на странице вопроса "Много баллов дам за решение..", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.