Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а

5-9 класс

затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася

Boooun 07 июня 2013 г., 2:13:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Grihan54
07 июня 2013 г., 2:54:25 (10 лет назад)

Var a,b,c:integer;
Begin
  read(a,b,c);
  if (a < 0) or (abs(a) > abs(b)) then a:= a - b
  else a:=a-b-1;
  writeln(a);
 
  if (a > 0) or (abs(a) > abs(c)) then a:= a + c
  else a:=a+c+1;
  writeln(a);
End.

+ 0 -
Ekaterina156
07 июня 2013 г., 3:45:33 (10 лет назад)

Var a,b,c:integer;
Begin
read(a,b,c);
if (a*(a-b) > 0) then a:= a - b
else a:=a-b-1;
writeln(a);

if (a*(a+c) > 0) then a:= a + c
else a:=a+c+1;
writeln(a);
End.

Ответить

Другие вопросы из категории

помогите пож-ста 92 задачу

Читайте также

В небоскрёбе n этажей и 1 подъезд,на каждом этаже по 3 квартиры,лифт останавливается только на не чётных этажах .Человек садится в лифт и нажимает номер

нужной ему квартиры.На какой этаж дома довезёт лифт человека.
(в паскале) плиззз помогите срочно надо

Известны размеры двух ящиков(длина, ширина, высота) .Определить объем какого ящика больше . Размеры меньшего ящика увеличить в два раза и снова сравнить

объемы ящиков . Вывести на экран больший объем. Составить программу в паскале.

Известны радиусы и координаты центров двух окружностей таких , что одна окружность не содержит внутри другой . Определить пересекаются ли эти окружности (расстояние между центрами должно быть меньше суммы радиусов). Определит площадь большей окружности. Составить программу в паскале

7. В доме у Пети установили новый лифт экспериментальной модели. В этом лифте все кнопки с номерами этажей заменены двумя кнопками. При нажатии на одну

из них лифт поднимается на один этаж вверх, а при нажатии на вторую - опускается на один этаж вниз. Пете очень по¬нравился новый лифт, и он катался на нем, пока не побывал на каждом из этажей хотя бы по одному разу. Известна последовательность кно¬пок, которые нажимал Петя: 1221221221. Каково количество этажей в доме у Пети? c какого этажа петя начал кататься на лифте? на каком этаже петя закончил свой эксперимент?

Пароль от почтового ящика в виде четырёхзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядо ведётся справа налево

начиная с нуля), циклически сдвигаются вправо, а нечётные-влево на колличество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо даёт нам 1 (7-8-9-0-1). Затем из нечётных цифр вычитается, а к чётным прибавляется1. В результате шифровки получилось число 3216. Определите пароль от электронной посты Васи

Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие чётные разряды (нумерация разрядов ведется вправо налево

начиная с нуля), циклически сдвигаются вправо, а нечетные-влево на количество позиций, равных номеру разряда. Так, например, циклический сдвиг цифры 7 на четыре позиции вправо дает нам 1 (7->8->9->0->1). Затем из нечётных цифр вычитается, а к чётным прибавляется 1. Далее оба шага повторяется еще один раз. В результате шифровки получилось число 3216. Определите пароль.



Вы находитесь на странице вопроса "В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.