Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Пожалуйста!) напишите программу которая вычисляет сколько раз введенное с клавиатуры число встречается в массиве ( в pascal)

5-9 класс

Wwwnatacha9 12 сент. 2013 г., 20:51:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lastel
12 сент. 2013 г., 21:48:36 (10 лет назад)

const n = 10;
var
  a: array[1..n] of integer;
  i, x, count: integer;
begin
  readln(x);
  for i := 1 to n do begin
    a[i] := random(100);
    write(a[i], ' ');
    if(a[i] = x) then inc(count);
  end;
  writeln;
  writeln('Число ', x, ' встречается в массиве ', count, ' раз');
end.

Ответить

Другие вопросы из категории

Людмила защищает свои пароли так: двигаясь от краёв пароля к центру, она меняет местами каждую вторую пару символов. Например, пароль pas sword

превращается в prawns pad.один из её защищенных паролей выглядит как ввт ева чоррсу. Выберете исходный пароль.

А) прочту Ева вот
Б)вот почту несу
В)встреча во рву
Г)вст рва чоерву

Помогите ответить на вопросы))))

1)надпись на клавише,находящейся рядом с клавишей Pause
2)надпись на клавише ,при нажатии на которую происходит отмена действия или выход из некоторого состояния
3) надпись на клавише , которую иногда называют самой главной клавишей
4)краткая надпись на клавише,переводящей курсор на страницу вниз

А8. В ячейке B1 записана формула =2*$A1. Какой вид приобретет формула, после того как ячейку B1 скопируют в ячейку C2? 1)

=2*$B1 2) =2*$A2 3) =3*$A2 4) =3*$B2Н

В6. Укажите сумму значений переменных и , которые получатся после выполнения следующего алгоритма.

a:=5; b:=3

если a*b<a+b, то

a:=a+b; b:=2a

иначе

a:=a-b; b:=3*a

конец ветвления.

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.



Вы находитесь на странице вопроса "Пожалуйста!) напишите программу которая вычисляет сколько раз введенное с клавиатуры число встречается в массиве ( в pascal)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.