Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

прооошу помогите перевести этот код delphi в паскаль,плиииз

10-11 класс

program TaskFormula;
uses
var x, a, xn, xk, dx, sum, multiplNegative: real;
countNegative: integer;
j,m,f:real;
y: Real;
begin
writeln('a --> ');
Read(a);
writeln(' xn --> ');
Read(xn);
writeln(' xk --> ');
Read(xk);
writeln(' dx --> ');
Read(dx);
sum := 0;
multiplNegative := 1;
countNegative := 0;
x := xn;
While (x <= xk) do begin if (a+x < 0) then begin f:=(a+x)*-1;
f:=ln(f)*(-1);
j:= RoundTo(abs(a-sqr(x)) * f,-5);
end
else
j:= RoundTo(abs(a-sqr(x)) * ln(a+x),-5);
m:= Power(sqr(x),1/3)+ Power(a,1/5);
if j<0 then begin j:=j*(-1);
j:= Power(j, 1/3);
j:=j*(-1);
end
else
j:= Power(j, 1/3);
y:= RoundTo(j/m,-5);
write('x= ',x:5:3,' ');
writeln('y= ',y:7:5);
if y<0 then
begin
sum := sum + y;
multiplNegative := multiplNegative * y;
inc(countNegative);
end;
x:= x + dx;
end;
writeln;
writeln(' y = ',countNegative);
writeln('y = ',sum:7:5);
writeln(' y = ',multiplNegative:7:5);
Readln;
end.

ПростоЗашла 12 марта 2014 г., 23:29:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelinafedori
13 марта 2014 г., 1:07:34 (10 лет назад)

var
  y, x, a, xn, xk, dx, sum, multiplNegative: real
  countNegative: integer
  j, m, f: real;

begin
  write('a --> '); 
  Read(a); 
  write(' xn --> '); 
  Read(xn); 
  write(' xk --> '); 
  Read(xk); 
  write(' dx --> '); 
  Read(dx);
  sum := 0; 
  multiplNegative := 1; 
  countNegative := 0; 
  x := xn;
  while (x <= xk) do 
  begin
    if (a + x < 0) then begin
      f := (a + x) * -1; 
      f := ln(f) * (-1); 
      j := Round(abs(a - sqr(x)) * f * 100000) / 100000; 
    end 
    else 
      j := Round(abs(a - sqr(x)) * ln(a + x) * 100000) / 100000; 
    m := Power(sqr(x), 1 / 3) + Power(a, 1 / 5); 
    if j < 0 then begin
      j := j * (-1); 
      j := Power(j, 1 / 3); 
      j := j * (-1); 
    end 
    else 
      j := Power(j, 1 / 3);
    y := Round(j / m * 100000) / 100000; 
    write('x= ', x:5:3, ' '); 
    writeln('y= ', y:7:5); 
    if y < 0 then 
    begin
      sum := sum + y; 
      multiplNegative := multiplNegative * y; 
      inc(countNegative); 
    end; 
    x := x + dx; 
  end; 
  writeln; 
  writeln(' y = ', countNegative); 
  writeln('y = ', sum:7:5); 
  writeln(' y = ', multiplNegative:7:5);
  Readln;
end.

Ответить

Другие вопросы из категории

Определите значение переменной z после выполнения фрагмента алгоритма:

z:=1;
repeat z:=z+2 until z=10;


1) 9
2) 11
3) 10
4) 1
5) ни один из вышеперечисленных ответов не верен, мой ответ:


И в целом объясните) как то меня ввела в тупик эта задача)

Читайте также

Помогите написать код решения в паскале.

Кощей Бессмертный зарыл клад на глубину 1 м. Этого ему показалось не
достаточно, он отрыл клад, углубил колодец до 2 м и снова зарыл. Этого ему
опять показалось мало, он отрыл клад,
углубил колодец до 3 м
и зарыл. Затем он проделал тоже, углубив
колодец до 4 м, потом до 5 м, 6 м и т.д. Известно, что колодец глубиной

Срочно! Помогите пожалуста! Нужно написать програмный код в турбо паскале! Заранее ОГРОМНОЕ СПАСИБО!! Заполнить массив из 10 элементов

случайными числами в интервале от 0 до 4 и вывести номера всех элементов, равных X.

Пример:

Исходный массив:

4 0 1 2 0 1 3 4 1 0

Что ищем? 0

A[2], A[5], A[10]

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, используется неравномерный двоичный код, позволяющий однозначно

декодировать полученную двоичную последовательность. Вот этот код: А – 011, Б – 000, В – 11, Г – 001, Д – 10. Можно ли сократить для одной из букв длину кодового слова так, чтобы код по-прежнему можно было декодировать однозначно? Коды остальных букв меняться не должны. Выберите правильный вариант ответа.



Вы находитесь на странице вопроса "прооошу помогите перевести этот код delphi в паскаль,плиииз", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.