Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дано число.Определить является ли оно кратным 5, оканчивается ли оно цифрой 7

5-9 класс

Fyyf210505 10 апр. 2014 г., 22:43:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hamish
11 апр. 2014 г., 0:41:50 (10 лет назад)

if a mod 5 =0

then writeln ('число делится на 5')

 

if a mod 7 =0

then writeln ('число делится на 7')

 

а - число, писал только тело программы

+ 0 -
Tigirana000
11 апр. 2014 г., 1:29:16 (10 лет назад)

var x:integer;

begin

readln(x);

if x mod 5=0 then writeln('kratno 5') else writeln('ne kratno 5');

if x mod 10=7 then writeln('konchaetsya na 7') else writeln('ne konchaetsya na 7');

end.

Ответить

Другие вопросы из категории

С1. Составить алгоритм

и написать программу на вычисление площади или периметра прямоугольника
, при условии, если а < b ,
тогда вычисляем периметр , иначе площадь . Каждую строку программы прокомментировать .
Входные данные а=10 , b=8
помогите решить 9 класс

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Дано число.Определить является ли оно кратным 5, оканчивается ли оно цифрой 7", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.