Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

определить какое количество букв <Ы> (и строчных и заглавных) встречается во введенноц с клавиатуры фразе. PascalABC

5-9 класс

Exclusive2 31 мая 2014 г., 2:48:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sodkari
31 мая 2014 г., 3:56:57 (9 лет назад)

program gt;
var a:string;
k,l,i,p:integer;
begin
readln(A);
l:=length(A);
k:=0;
for i:=1 to l do
begin
p:=ord(a[i]);
if(p>191)and(p<224)then a[i]:=chr(p+32);
if(a[i]='ы')then k:=k+1;
end;
writeln(k);
end.

Ответить

Другие вопросы из категории

Номер 28!

Даны действительное число а,натуральное число n. Вычислите:
S=1/a+1/a(во 2 степени)+1/а(в 4 степени)+..1/а(в степени 2n-2)

В турбо паскале

Написать программу в паскале: Имеется кусок ткани длинной M метров. От него последовательно отрезаются куски равной длины. Все данные по использованию

ткани заносятся в компьютер. Компьютер должен выдать сообщение о том, что материала не хватает, если будет затребован кусок ткани больше длины, чем имеется.

Читайте также

Частотный словарь русского языка — словарь вероятностей (частот) появления букв в произвольном тексте – приведен ниже. Определите, какое количество

информации несет каждая буква этого словаря.

Символ

Частота

Символ

Частота

Символ

Частота

Символ

Частота

о 0.090 в 0.035 я 0.018 ж 0.007
е, е 0.072 к 0.028 Ы, 3 0.016 ю, ш 0.006
а, и 0.062 м 0.026 ь, ъ, б 0.014 ц, щ, э 0.003
т, н 0.053 д 0.025 ч 0.013 ф 0.002
с 0.045 п 0.023 й 0.012
р 0.040 У 0.021 X 0.009
2. Используя результат решения предыдущей задачи, определите количество информации в слове “компьютер”.

Частотный словарь русского языка — словарь вероятностей (частот) появления букв в произвольном тексте – приведен ниже. Определите, какое количество

информации несет каждая буква этого словаря.

Символ

Частота

Символ

Частота

Символ

Частота

Символ

Частота

о 0.090 в 0.035 я 0.018 ж 0.007
е, е 0.072 к 0.028 Ы, 3 0.016 ю, ш 0.006
а, и 0.062 м 0.026 ь, ъ, б 0.014 ц, щ, э 0.003
т, н 0.053 д 0.025 ч 0.013 ф 0.002
с 0.045 п 0.023 й 0.012
р 0.040 У 0.021 X 0.009
2. Используя результат решения предыдущей задачи, определите количество информации в слове “компьютер”.

Частотный словарь русского языка — словарь вероятностей (частот) появления букв в произвольном тексте – приведен ниже. Определите, какое количество

информации несет каждая буква этого словаря.

Символ

Частота

Символ

Частота

Символ

Частота

Символ

Частота

о 0.090 в 0.035 я 0.018 ж 0.007
е, е 0.072 к 0.028 Ы, 3 0.016 ю, ш 0.006
а, и 0.062 м 0.026 ь, ъ, б 0.014 ц, щ, э 0.003
т, н 0.053 д 0.025 ч 0.013 ф 0.002
с 0.045 п 0.023 й 0.012
р 0.040 У 0.021 X 0.009
2. Используя результат решения предыдущей задачи, определите количество информации в слове “компьютер”.

Как создать в HTML анкету с формой с сылкой на почту? Какие вопросы можно написать? Вот пример одного вопроса: <html>

<head>
<title></Title>
</head>
<body>
какой браузер вы используете?
<select name="браузер">
<option selected> Internet Explorer
<option> Opera
<option> Mozila
</select>
</body>
</html>

1. Загадано число из промежутка от 1 до 256. Какое количество информации необходимо для угадывания числа из этого промежутка?

2. В корзине лежат 4 красных и 28 чёрных кубика. Какое количество информации несёт сообщение о том, что достали красный кубик?
3. При составлении сообщения использовали 16-символьный алфавит. Каким будет информационный объём такого сообщения, если оно содержит 5120 символов?
4. Сообщение занимает 5 страниц. На каждой странице по 80 строк. В каждой строке по 40 символов. Найдите информационный объём такого текста, если при его составлении использовали 256-символьный алфавит.
5. Выразите 32 Мбайт в битах и 16 Гбайт в байтах.
6. Решите уравнение а) 4 Гбайта=2^x байт=2^y бит; б) 8^x Кбайт=32 Гбайт
7. Модем передаёт данные со скоростью 7680 бит/с. Передача текстового файла заняла 1,5 мин. Определите, сколько страниц содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode, а на одной странице - 400 символов.
8. Какой формат кода применим для кодировки алфавита в котором 299 символов?
9. Дан алфавит { # D W K J % * + = > $ @ & ; }. Закодируйте его в минимально возможном формате байта.
10. Некоторое устройство передаёт в секунду один из семи сигналов. Сколько различных сообщений длиной в 3с можно передать при помощи этого устройства?



Вы находитесь на странице вопроса "определить какое количество букв &lt;Ы&gt; (и строчных и заглавных) встречается во введенноц с клавиатуры фразе. PascalABC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.