Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Дано натуральное число.найти количество цифр данного числа больших b(b вводится с клавиатуры)

10-11 класс

Karinabesschas 21 дек. 2014 г., 11:34:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Roman20044002vra
21 дек. 2014 г., 12:41:30 (9 лет назад)

Паскаль:

uses crt;
var
a, b, c, code,i, k : integer;
st: string;
begin
write ('N = '); readln (a);
write ('B =');readln (b);
str (a, st);
for i:= 1 to length (st) do begin
val (st[i],c, code);
if c>b then k:= k+1; end;
writeln (k);
readkey;
end.

Ответить

Другие вопросы из категории

Напишите программу, которая

позволяет ввести три вещественных числа и выводит на экран:


разность
целых частей первого и второго чисел;
косинус
удвоенного произведения первого на третье;
сумму
квадратов синуса второго числа и косинуса третьего.


Все вещественные числа должны
быть выведены в форме с фиксированной точкой с двумя знаками после запятой;
перед каждым вычисленным значением должны идти пояснительный текст и выражение.

Читайте также

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)



Вы находитесь на странице вопроса "Дано натуральное число.найти количество цифр данного числа больших b(b вводится с клавиатуры)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.