Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

. Напишите программу в паскале, которая меняет местами значения целых переменных M и N без использования дополнительной переменной. Ниже представлен рекоме

5-9 класс

ндуемый вид экрана во время работы программы (данные вводимые пользователем выделены полужирным шрифтом).

Введите число M=> 5
Ведите число N=> 7
-----------------------
Новые значения:
M=7, N=5

99alina 09 февр. 2017 г., 8:14:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mikita
09 февр. 2017 г., 9:40:10 (7 лет назад)

var m, n, x:integer;
begin
writeln('Введите число M=> ');
readln(m);
writeln('Введите число N=> ');
readln(n);
x:=m;
m:=n;
n:=x;
writeln('Новые значения:');
writeln('M=',m,', ', 'N=',n);
end.

+ 0 -
ТанкистПавел
09 февр. 2017 г., 11:19:45 (7 лет назад)

решение паскале во вложении

Ответить

Другие вопросы из категории

У исполнителя Калькулятор две команды : 1. прибавь 1. 2. прибавь 2. Первая из них увеличивает число на экране на 1 , вторая --на 2. Сколько различных

чисел можно получить из числа 2 с помощью программы , которая содержит не более 4 команд ?
У исполнителя Утроитель две команды которым присвоены номера :
1.вычти 1
2. умножь на 3
Первая из них уменьшает число на экране на 1, вторая -увеличивает его в три раза . Запишите порядок команд в алгоритме получения из числа 6 числа 10 , содержащем не более 5 команд , указывая лишь номера команд . (Например , 21211--это алгоритм :умножь на 3
вычти 1
умножь на 3
вычти 1
вычти 1 , который преобразует число 2 в число 13 ).
Если таких алгоритмов более одного , то запишите любой из них .

Читайте также

Задача1Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей

схеме, чтобы в переменной а оказалось первоначальное значение переменной с, в переменной b – значение а, в переменной с – значение b.(Пояснение: Используйте оператор присваивания и одну дополнительную переменную)

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r

или s. 5. Напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a;b), или 0 в противном случае

Помогите пожалуйста)

Нужно составить программу (в паскаль),которая бы высчитывала значение следующего выражения....



Вы находитесь на странице вопроса ". Напишите программу в паскале, которая меняет местами значения целых переменных M и N без использования дополнительной переменной. Ниже представлен рекоме", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.