Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1. даны числа а,в,с,d. найти максимальное, присвоить значение y 2. даны числа а,в,с. поменять их значения местами. СОСТАВИТЬ

5-9 класс

БЛОК-СХЕМЫ

Denshepa2003 07 авг. 2014 г., 3:21:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
16лет
07 авг. 2014 г., 5:49:44 (9 лет назад)

uses crt; const N=10; var w,q,c,i,min,max: integer; a: array[1..N] of integer; begin randomize; min:=0; max:=0; for i:=1 to N do begin a[i]:=random(30)-6; write(a[i]:3); if A[i]max then begin max:=A[i]; w:=i; end; end;writeln; c:=A[w]; A[w]:=A[q]; A[q]:=c; writeln('наибольший и наименьший местами'); for i:=1 to N do write(A[i]:3); writeln; c:=A[q]; A[q]:=A[10]; A[10]:=c; writeln('наибольший v konec'); for i:=1 to N do write(A[i]:3); readln; end.

Ответить

Другие вопросы из категории

Читайте также

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Помогите пожалуйстааааа, хотя бы не все но некоторые помогите сделать прошууу:) 1. Перевести данное число из десятичной системы счисления в

двоичную, восьмеричную и шестнадцатеричную системы счисления. а) 113(10); б) 875(10); в) 535,1875(10); г) 649,25(10); д) 6,52(10). 2. Перевести данное число в десятичную систему счисления. а) 11101000(2); б) 1010001111(2); в) 1101101000,01(2); г) 1000000101,01011(2); д) 1600,14(8); е) 1E9,4(16).

1. Перевести данное число из десятичной СС в двоичную СС, восьмеричную и шестнадцатеричную СС. а) 500(10); б) 675(10); в) 810,25(10); г)

1017,25(10); д) 123,72(10)

2. Перевести данное число в десятичную СС.

а) 1101010001(2); б) 100011100(2); в) 1101110001,011011(2); г) 110011000,111001(2); д) 1347,17(8); е) 155,6C(16)

1. Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления А) 273(10) Б) 156,25(10)

2. Перевести данное число в десятичную систему счисления. а) 1100000000(2) б) 1011001101,00011(2) в)1017,2(8) г) 111,В(16)



Вы находитесь на странице вопроса "1. даны числа а,в,с,d. найти максимальное, присвоить значение y 2. даны числа а,в,с. поменять их значения местами. СОСТАВИТЬ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.