Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

1)Даны два целых числа А и В (вводятся с клавиатуры, A<B). Найти и вывести все произведения целых чисел от А до В. 2)Найти сумму цифр целого числа А

5-9 класс

(вводится с клавиатуры). 3)Найти количество целых трехзначных чисел, произведение цифр которых равно N(вводится с клавиатуры). составте программу на Паскале. НЕ ПИШИТЕ РЕШЕНИЯ С ИНТЕРНЕТА , Я ИХ САМА УЖЕ ПОСМОТРЕЛА, ВСЁ НЕ ТО

ChrissShy 10 окт. 2015 г., 6:37:18 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кукабука
10 окт. 2015 г., 9:16:58 (8 лет назад)

1) var
a,b,i,n:integer;
begin
n:=1;
readln(a);
readln(b);

for i:=a to b do
n:=n*i;
writeln(n);
end.

 

2) 

var
n,s:integer;
begin
read(n);

s:=0;
repeat
s:=s+(n mod 10);
n:=n div 10;
until n=0;
writeln (s);
end.

 

3) 

var
n,k,i:integer;
begin
read(n);
for i:= 100 to 999 do begin
if (i div 100)*((i div 10) mod 10)*(i mod 10)=n then
k:=k+1;
end;
writeln (k);
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста))))

Информационная емкость человеческой яйцеклетки приблизительно равна 2 в 33 степени битам. Сколько дисков емкостью 600 Мбайт потребуется для размещения этой информации?

помогите 10101+1011 11001-1111
Пожалуйста помогите!!! Переведите:

128 бит в Кбайты
40 Кбайт в биты
40 Кбайт в байты
1792 Кбайт в Мбайты

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B.

Формат входных данных
Первая строка входного файла содержит два целых числа A и B (1 <= A, B <= 10^9).
Формат выходных данных
Выведите ответ к задаче.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "1)Даны два целых числа А и В (вводятся с клавиатуры, A&lt;B). Найти и вывести все произведения целых чисел от А до В. 2)Найти сумму цифр целого числа А", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.