Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите пункты а) и б) пожалуйста!!

5-9 класс

а) Задан линейный массив. Преобразовать его элементы по следующему правилу:
Элементы, большие числа X , заменить на X, а элементы меньшие Y, на число -Y. Числа X и Y вводятся (x>y).
б) Задан линейный массив. Преобразовать его элементы по следующему правилу:
Элементы, кратные 3 оставить без изменения, а остальные заменить остатком от деления на 3.

Lord156 11 февр. 2017 г., 4:45:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yatan
11 февр. 2017 г., 5:25:30 (7 лет назад)

а)Начало -> 
 Ввод массива -> 
 Ввод X -> 
 Ввод Y ->
 Если X>Y
 ->no->End
 ->yes->
 p=0 ->
 ∨-> если элемент массива (p) > X, элемент массива (p) = X ->
  если элемент массива (p) < Y, элемент массива (p) = Y ->
  p = p + 1 -> если p больше размера массива
      если нет -> Возврат на ∨
      если да -> Вывод массива -> Конец

б)Начало -> 
 Ввод массива -> 
 p=0 ->
 ∨-> если элемент массива (p) %(остаток от деления на) 3=0
->yes->
->no-> элемент массива (p) =элемент массива (p)%3
->p=p+1
->если p больше размера массива
      если нет -> Возврат на ∨
      если да -> Вывод массива -> Конец
      

+ 0 -
Kaifat7474
11 февр. 2017 г., 7:40:48 (7 лет назад)

нужен алгоритм?

+ 0 -
Lol783
11 февр. 2017 г., 8:16:57 (7 лет назад)

Желательно.

+ 0 -
Agamaliev99
11 февр. 2017 г., 10:01:51 (7 лет назад)

ок

Ответить

Другие вопросы из категории

Проверьте есть ли ошибки ,срочно пожалуйста program n_4 ; var p ,m ,v:real;

begin
writeln ( 'Определение плоности вещества ')
write :( ' Введите массу вещества ' )
writeln( 'Определение массы вещества ')
р=m\v
writeln( ' p=')
end.

Расчёт прогноза погоды на современном компьютере с быстродействием 1 млн.операций в секунду длится в

течение 1 часа. Оцените, сколько времени понадобилось бы для этого человеку, имеющему в своём распоряжении арифмометр (механический калькулятор), выполнение одной операции на котором занимает 10 секунд.

Хрестоматия содержит 256 страниц, на каждой из которых в среднем по 20 строк из 40 символов каждая. Сколько кбайт составляет информационный объем

текстового файла с хрестоматией, если для кодирования текста использована 8-битная кодировка КОИ-8?

Читайте также

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Решите под 3 и 5 пожалуйста
у исполнителя Арифметики 2 команды,которым присвоены номера: 1)прибавь 2 2)умножь на 3.Первая из них увеличивает число на экране на 2,вторая утраивает

его. запишите порядок команд в программе преобразования числа 12 в число 122,содержащей не более одной,то запишите любую из них. Ребят прошу объяснить и решить,очень надо,СРОЧНО!ПОМОГИТЕ ПОЖАЛУЙСТА!ОЧЕНЬ ОЧЕНЬ НАДООО!ПЛИИИЗ



Вы находитесь на странице вопроса "Решите пункты а) и б) пожалуйста!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.