Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Прошу помогите на Зачёте: Дано массив целых чисел A[N]. Проверьте, есть ли в нем отрицательные элементы. Если есть, найдите наибольшее i, при

10-11 класс

котором A[i]<0, иначе выведите сообщение.

Qwewqe1234 26 сент. 2014 г., 8:08:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Violettasharayuk
26 сент. 2014 г., 8:42:02 (9 лет назад)

Программа находит наибольшее отрицательное число из n чисел, так как рандом состоит из положительных и отр. чисел, не стал писать else. Код кривой, но рабочий :)
program asd;
USES crt;
var a:array[1..100]of integer;
i,n,max:integer;
BEGIN
clrscr;
Writeln('Vvedite kol-vo chisel: ');
Readln(n);
for i:=1 to n do
begin
A[i]:=random(20)-10;
Write(' ',A[i]);
end;
max:=A[1];
for i:=2 to n do
begin
if (A[i]<0) then
begin
if (A[i]<max) then max:=A[i]
end;
end;
Writeln;
Writeln('Maksimalnoe chislo pri A[i]<0 = ',max);
END.

+ 0 -
Galinaklejn
26 сент. 2014 г., 11:17:17 (9 лет назад)

Еще надо или уже все ?

+ 0 -
Meay
26 сент. 2014 г., 12:49:12 (9 лет назад)

надо!))) прошу помогите

+ 0 -
Ksenia12301
26 сент. 2014 г., 15:08:53 (9 лет назад)

С меня тысяча благодарностей!)

+ 0 -
Dana210
26 сент. 2014 г., 17:55:30 (9 лет назад)

Ам? :(

+ 0 -
79522257925
26 сент. 2014 г., 20:43:33 (9 лет назад)

Делаю, делаю

Ответить

Другие вопросы из категории

Задача 2. В корзине лежат 4 красных и 8 черных клубков шерсти. Какое количество информации несут сообщения о том, что достали красный

или черный клубок шерсти?

!!! Для задачи 2 необходимо использовать формулы вероятностного подхода.

У двовимірному масиві Х[1..5,1..5]цілих

чисел знайти найменший елемент серед елементів побічної
д

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20].

Найти номер первого отрицательного элемента, делящегося на 5 с остатком 2.напишите пожалуйста программу в лазарусе



Вы находитесь на странице вопроса "Прошу помогите на Зачёте: Дано массив целых чисел A[N]. Проверьте, есть ли в нем отрицательные элементы. Если есть, найдите наибольшее i, при", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.