Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Поменять местами содержимое ячеек массива с максимальным и минимальными значениями.

10-11 класс

Пожалуйста, помогите с информатикой:(

Deh56lfybk66 07 нояб. 2014 г., 8:26:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
0705julia
07 нояб. 2014 г., 10:25:49 (9 лет назад)

program chik;
label 1;
var a:array[1..1000]of integer;
p,w,i,n,min,max,l:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
min:=a[1];max:=a[1];
for i:=2 to n do
begin
if(a[i]>max)then begin
max:=a[i];
goto 1;
end;
if(a[i]<min)then min:=a[i];
1:
end;
p:=max;l:=min;
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=l;
if(a[i]=min)then a[i]:=p;
end;
for i:=1 to n do
begin
write(a[i],' ');
end;
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА, СРОЧНО!

Даны целые положительные числа m,n и k. сформировать целочисленную матрицу размером m*n, у которой все элементы имеют значения k+i+j (i=1,2..m; j=1,2..n)

Задача 2. В корзине лежат 4 красных и 8 черных клубков шерсти. Какое количество информации несут сообщения о том, что достали красный

или черный клубок шерсти?

!!! Для задачи 2 необходимо использовать формулы вероятностного подхода.

Читайте также

ПОМОГИТЕ! Нужно написать программу в паскале. 1. Поменяйте местами первый элемен массива А(8) с наибольшим элементом, а

последний - с наименьшим элементом массива. Случайные числа в [10;99]

2. Посчитайте сумму чётных элементов массива А(8). Случайные числа в [1;9]

3. Найдите номер нулевого элемента данного одномерного массива А(10). Случайные числа в [-10;10]

Помогите пожалуйста, нужно сделать в паскале, в экселе, и блок-схему!

(задание номер 5 на фото)

Дан одномерный массив А размерностью 16. Определить максимальное значение среди нечетных элементов массива, и минимальное среди четных элементов массива. Получить сумму максимального и минимального значений элементов массива и преобразовать данный массив по принципу из значений нечетных элементов вычесть сумму, а к четным элементам прибавить сумму. Все первоначальные элементы массива вводятся с клавиатуры.

Сформировать двумерный массив M(3,4) чисел 22,3,5,7,12,15,17,8,9,1,23,45; Вывести на экран в виде таблицы; Найти максимальные и минимальные значения .

Заменить элементы первой строки на нули. ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ НАДО!!!!!

дан двумерный массив,найти максимальное и минимальное значение .Я новенький в этом деле,вот попытался сам,посмотрите и обьясните что не правильно ,пожал

уйста .

program zaza;
var
i,j,n,m,max,min:integer;
a:array[1..10,1..10] of integer;
begin
writeln ('vvedite chislo n');
writeln ('vvedite chislo m');
for i:=1 to n do
for j:=1 to m do
begin
writeln ('vvedite elementu massiva',i,j);
end;
for i:=1 to n do
for j:=1 to m do
begin
if a[i,j] > max then
max:= a[i,j];
if a[i,j] < min then
min:=a[i,j];
end;
writeln('max','min')
end.

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.



Вы находитесь на странице вопроса "Поменять местами содержимое ячеек массива с максимальным и минимальными значениями.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.