Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Ввести с клавиатуры значение площади прямоугольного треугольника.( треугольник равнобедренный). Вывести на экран значение катетов, гипотенузы.

10-11 класс

Использовать процедуру для получения результатов "Выходные переменные"

мыыыыыыыы 02 дек. 2014 г., 17:46:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mariesk
02 дек. 2014 г., 19:25:57 (9 лет назад)

program Project2;
 {$APPTYPE CONSOLE}
var s,a,c:Real;
begin 
 Readln(s); 
 s:=s*2; 
 a:=Sqrt(s); 
 c:=Sqr(a)+sqr(a); 
 writeln('katetu',a:0,' gipotenusa',c:0); 
 readln;
end.

Ответить

Другие вопросы из категории

Поменять местами содержимое ячеек массива с максимальным и минимальными значениями.

Пожалуйста, помогите с информатикой:(

ПОМОГИТЕ ПОЖАЛУЙСТА, СРОЧНО!

Даны целые положительные числа m,n и k. сформировать целочисленную матрицу размером m*n, у которой все элементы имеют значения k+i+j (i=1,2..m; j=1,2..n)

Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

1 В зависимости от того что вводится с компьютера программа должна посчитать площадь треугольника по одной из двух формул S=1/2 основания на h либо по форм

уле Герона

2 В зависимости от номера класса введенного с клавиатуры вывести на экран что это начальная, средняя, старшая или выпускное звено. Выпускное звено 9 и 11 классы.

помоги пожалуйстаа) “Солнце есть спутник Земли”;б) “2+34”;в) “сегодня отличная погода”;г) “в романе Л.Н. Толстого “Война и мир” 3 432 536 слов”;д)

“Санкт-Петербург расположен на Неве”;е) “музыка Баха слишком сложна”;ж) “первая космическая скорость равна 7.8 км/сек”; з) “железо — металл”;и) “если один угол в треугольнике прямой, то треугольник будет тупоугольным”;к) “если сумма квадратов двух сторон тре4угольника равна квадрату третьей, то он прямоугольный”.[ Ответ ]
5.2. Укажите, какие из высказываний предыдущего упражнения истинны, какие — ложны, а какие относятся к числу тех, истинность которых трудно или невозможно установить. [ Ответ ]
5.3. Приведите примеры истинных и ложных высказываний: а) из арифметики; б) из физики;в) из биологии; г) из информатики;д) из геометрии; е) из жизни.[ Ответ ]
5.4. Сформулируйте отрицания следующих высказываний или высказывательных форм: а) “Эльбрус — высочайшая горная вершина Европы”;б) “2>=5”;в) “10<7”;г) “все натуральные числа целые”;д) “через любые три точки на плоскости можно провести окружность”;е) “теннисист Кафельников не проиграл финальную игру”;ж) “мишень поражена первым выстрелом”;з) “это утро ясное и теплое”;и) “число n делится на 2 или на 3”;к) “этот треугольник равнобедренный и прямоугольный”;л) "на контрольной работе каждый ученик писал своей ручкой".[ Ответ ]
5.5. Определите, какие из высказываний (высказывательных форм) в следующих парах являются отрицаниями друг друга, а какие нет: а) “5<10”, “5>10”;б) “10>9”, “10<=9”;в) “мишень поражена первым выстрелом”, “мишень поражена вторым выстрелом”;г) “машина останавливалась у каждого из двух светофоров”, “машина не останавливалась у каждого из двух светофоров”,д) “человечеству известны все планеты Солнечной системы”, “в Солнечной системе есть планеты, неизвестные человечеству”;е) “существуют белые слоны”, “все слоны серые”;ж) “кит — млекопитающее”, “кит — рыба”;з) “неверно, что точка А не лежит на прямой а”, “точка А лежит на прямой а”;и) “прямая а параллельна прямой b”, “прямая a перпендикулярна прямой b”;к) “этот треугольник равнобедренный и прямоугольный”, “этот треугольник не равнобедренный или он не прямоугольный”.[ Ответ ]
5.6. Определите значения истинности высказываний: а) “наличия аттестата о среднем образовании достаточно для поступления в институт”;б) “наличие аттестата о среднем образовании необходимо для поступления в институт”;в) “если целое число делится на 6, то оно делится на 3”;г) “подобие треугольников является необходимым условием их равенства”;д) “подобие треугольников является необходимым и достаточным условием их равенства”;е) “треугольники подобны только в случае их равенства”;ж) “треугольники равны только в случае их подобия”;з) “равенство треугольников является достаточным условием их подобия”;и) “для того, чтобы треугольники были неравны, достаточно, чтобы они были неподобны”;к) “для того, чтобы четырёхугольник был квадратом, достаточно, чтобы его диагонали были равны и перпендикулярны”.[ Ответ ]



Вы находитесь на странице вопроса "Ввести с клавиатуры значение площади прямоугольного треугольника.( треугольник равнобедренный). Вывести на экран значение катетов, гипотенузы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.