Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу.

5-9 класс

Для целого числа K от 1 до 99 напечатать фразу: "Мне K лет, учитывая, что может быть год, лет, года.
Год: 1, 21, 31, 41... (n mod 10=1).
Лет: 5-20, 25-30, 35-40, 45-50... (n mod 10=0, 5, 6, 7, 8, 9).
Года: 2, 3, 4, 22-24, 32-34, 42-44... (n mod 10=2, 3, 4).

Katyakrychkova 05 янв. 2015 г., 3:59:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svoboden
05 янв. 2015 г., 5:56:21 (9 лет назад)

var k:integer;
begin
readln(k);
case (k mod 10) of
 1 : writeln ('Мне ',k,' год'); 
 0, 5, 6, 7, 8, 9 : writeln ('Мне ',k,' лет'); 
 2, 3, 4 : writeln ('Мне ',k,' года');
end;
end.

Вот рабочее решение

Ответить

Другие вопросы из категории

В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика(не заглядывая в него), чтобы среди вынутых шаров: 1) оказался

хотя бы один чёрный 2) оказался хотя бы один белый 3) оказались хотя бы два чёрных 4) оказались хотя бы два белых? Пожалуйста, помогите!

Читайте также

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, как

соотносятся между собой два произвольных числа A и B.

2. Фирма осуществляет набор сотрудников. Условия приема требуют не менее 3 лет рабочего стажа и возраст не более 35 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям.



Вы находитесь на странице вопроса "Написать программу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.