Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ВОПРОС №216817 (ТИП: C) Дано трехзначное число. В нем зачеркнули последнюю цифру и приписали ее в начале. Написать программу, которая находит

5-9 класс

получаемое число.

КариНаж 19 мая 2015 г., 16:05:52 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Antropovaninac
19 мая 2015 г., 16:53:29 (8 лет назад)

var a,a1,a2,a3: integer;
begin
write ('Введите трехзначное число: '); read (a);
a1:=a div 100 mod 10;
a2:=a mod 100 div 10;
a3:=a mod 10;
writeln ('Полученное число: ',a3,a1,a2);
end.

Ответить

Читайте также

1. Если дано трехзначное число, например 123 его можно представить в

виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу,
которая, получая от пользователя трехзначное число, будет определять из каких цифр
оно состоит и выводить их через пробел (например, 1_2_3).

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо



Вы находитесь на странице вопроса "ВОПРОС №216817 (ТИП: C) Дано трехзначное число. В нем зачеркнули последнюю цифру и приписали ее в начале. Написать программу, которая находит", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.