Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

С клавиатуры вводят два слова,каждое из которых распологается на одной строке.Составте программу,которая выводит эти слова в алфавитном порядке.

10-11 класс

ВикториЯ041002 19 апр. 2016 г., 2:16:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sabina87
19 апр. 2016 г., 4:14:49 (7 лет назад)

Пример на паскале держи:
Var s,sl:string;    
A:array[1..30] of string;//массив строк, который будет хранить слова
n,i,j:byte;
Begin    
write('Введите строку: ');
readln(s);    
s:=s+' ';n:=0;    
While Pos(' ',s)>0 do    
Begin      
if Copy(s,1,Pos(' ',s)-1)<>'' then      
Begin        
inc(n);        
A[n]:=Copy(s,1,Pos(' ',s)-1);      
End;      
Delete(s,1,Pos(' ',s));    
End;    
For i:=n downto 2 do    
For j:=2 to i do      
if A[j]<A[j-1] then      
Begin        
sl:=A[j];        
A[j]:=A[j-1];        
A[j-1]:=sl;      
End;    
For i:=1 to n do     
s:=s+A[i]+' ';    
writeln('В алфовитном порядке = ',s);    
readln;
End.

Ответить

Другие вопросы из категории

Читайте также

Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе

напишите программу ,которая

запрашивает значения четырех переменных (A,B,C,D) типа integer и выводит их сумму. ввод первой пары значений (A,B) произведите на одной строке ,ввод другой пары. (C,D) ; на другой строке. Результат выведите на отдельную строку и курсор оставьте на той же строке. Эту рограмму надо написать на языке pascal

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

1. На одной улице стоят в ряд 4 дома, в которых живут 4

человека: Андрей, Евгений, Василий и Михаил. Известно, что каждый из них
владеет ровно одной из следующих профессий: Банкир, Учёный, Хирург и Окулист,
но неизвестно, кто какой и неизвестно, кто в каком доме живёт. Однако,
известно, что:

На одной улице стоят в ряд 4 дома, в которых живут 4

человека: Семён, Николай, Артур и Роман. Известно, что каждый из них владеет
ровно одной из следующих профессий: Врач, Художник, Егерь и Тренер, но
неизвестно, кто какой, и неизвестно, кто в каком доме живёт. Однако известно,
что:

1)



Вы находитесь на странице вопроса "С клавиатуры вводят два слова,каждое из которых распологается на одной строке.Составте программу,которая выводит эти слова в алфавитном порядке.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.