Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Pascal

5-9 класс

Дана строка. Подсчитать количество слов, заканчивающихся буквой и.
Например,

Мышки ели шишки.

Евгеша15 01 авг. 2013 г., 10:02:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TetyanaCh
01 авг. 2013 г., 11:43:27 (10 лет назад)

var
  s: string := 'Мышки ели шишки.';
  a: set of char := ['а'..'я', 'ё'];
  n, i: integer;
begin
  s := LowerCase(s) + ' ';
  for i := 2 to Length(s) do
    if not (s[i] in a) and (s[i-1]='и') then
      n := n + 1;
  writeln(n);
end.

Ответить

Другие вопросы из категории

Срочно!Помогите! Пожалуйста!
Решит в паскаль!!!
Незнайка написал послание и подписался одним зашифрованным словом, используя равномерный код, состоящий из 0 и 1. Им был выбран самый простой способ

кодировки текста 33 букв алфавита. Знайка быстро расшифровал сообщение, распознав количество букв в нем, и посоветовал Незнайке быть скромнее и изобретательнее. Расшифруйте слово - подпись:

001111000110001100010010000001010011010000000011

помогите! вопрос внутри!

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.