Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Решите пожалуйста,очень нужно! С клавиатуры вводят слово и символ. Составьте программу,которая:а)проверяет,есть ли в этом слове заданный

10-11 класс

символ;б)определяет позицию заданного слова;в)подсчитывает количество вхождений заданного символа.

Mamini 29 апр. 2014 г., 18:41:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bigfriend
29 апр. 2014 г., 21:36:12 (9 лет назад)

program p_1;
var
slovo,simval:string;
i,k:integer;
begin
k:=0;
write('Введите слово ');
readln(slovo);
write('Введите символ ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
writeln('Да, встречается ',k,' раз, на позиции ',i)else writeln('Нет');
writeln;
end.

Ответить

Другие вопросы из категории

какая ошибка в записи на языке паскаль?

x=0 and y<>8

Читайте также

помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая: а) определяет, есть ли во

введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя....

Помогите решить пожалуйста!!! Циклический оператор на ЯП Паскаль: Каждая бактерия делится на две в течение

одной минуты.

В начальный момент времени имеется одна бактерия.

Составьте программу, которая рассчитывает количество бактерий на заданное пользователем с клавиатуры целое значение момента времени (15 минут, 7 минут и т.п.)



Вы находитесь на странице вопроса "Решите пожалуйста,очень нужно! С клавиатуры вводят слово и символ. Составьте программу,которая:а)проверяет,есть ли в этом слове заданный", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.